bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

back button arrow misaligned on mouseover

RESOLVED WORKSFORME

Status

SeaMonkey
Themes
--
trivial
RESOLVED WORKSFORME
17 years ago
10 years ago

People

(Reporter: Christopher W. Curtis, Assigned: Joe Hewitt (gone))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5+) Gecko/20011010
Netscape6/6.1b1
BuildID:    2001120806

When I move the mouse onto the back button, the green arrow ("classic" skin)
shifts a pixel or two to the right.  Moving onto the dropdown part of the button
shifts it back to the position it is in when the mouse is not on the button at
all.  The forward button does not exhibit this same behavior, so I'm assuming
one is wrong.

Reproducible: Always
Steps to Reproduce:
1. Move mouse onto back button
2. Move mouse onto dropdown part
3. Move mouse back into the back button


Actual Results:  The arrow appears to shift to the right

Expected Results:  No shift, or the same shifting with the forward button.
QA Contact: sairuh → claudius

Comment 1

17 years ago
-> default assignee
Assignee: pchen → trudelle
Status: UNCONFIRMED → NEW
QA Contact: claudius → sairuh
(Reporter)

Comment 2

17 years ago
Still present in 2002012208, but different.  It works now when I go over the
dropdown arrow, but if I move the mouse to the grippy bar, sometimes the arrow
shifts left and sometimes it doesn't.

Comment 3

17 years ago
->themes
Assignee: trudelle → hewitt
Status: NEW → UNCONFIRMED
Component: XP Apps → Themes
QA Contact: sairuh → pmac

Comment 4

17 years ago
WFM Linux 2002-04-04-08

Reporter: Do you still see this bug with a recent nightly build?

Nightly build is available at:
http://ftp.mozilla.org/pub/mozilla/nightly/latest/

Thanks
(Reporter)

Comment 5

17 years ago
I downloaded 20020404 but the mail client is *way* too buggy.  I'm still seeing
it in 2002031808 ...

Yes, still present in 2002040410 ... if you move your mouse over the grippy bar,
the arrow, and the pulldown, and move it back and forth, back and forth, you
will (I hope it's not just me) see the green arrow jump one pixel to the left. 
It almost looks like the dropdown arrow is resetting it to the correct position
but the grippy bar pulls it off by one.  This seems a pretty reliable way to
reproduce it.

If I move the mouse slowly over the three bars and outside the window (which
then loses focus) it will jump a pixel left and then jump right back, maybe once
every 100 times I do it.  If I do it quickly, however, it jumps and gets stuck
maybe every other time or more often.

Comment 6

17 years ago
Works for me on 1.0RC1.

On mouseover, the back arrow is simply colored with a slightly lighter green. 
Absolutely no shifting in any direction.  Moving the mouse away repaints the
arrow without any movement.

Please try the latest release or a nightly build.
(Reporter)

Comment 7

17 years ago
Build 2002042210 looks good on the computer here (Linux 2.4.18).  No shifting
noticeable.  I'll have a look on the original machine in a couple more days...

Comment 8

16 years ago
WFM based on comment 7
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.