Closed Bug 1143692 Opened 5 years ago Closed 5 years ago

Enable Sync signup/signin from an iframe embedded in the first run experience.

Categories

(Firefox :: Sync, defect)

37 Branch
x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1150222

People

(Reporter: stomlinson, Unassigned)

References

Details

A user should be able to sign up/in to Firefox Sync as part of the redesigned Firefox Desktop first run experience. The first run experience is a web page that will embed the Firefox Accounts content server in an iframe.

100 mile high overview of what should happen:

* The first run experience must be able to open Firefox Accounts in an iframe.
* The first run experience must be able to indicate to Firefox Accounts the sign in is for Sync.
* Firefox must listen for messages from Firefox Accounts that indicate the user is signed in to Sync.
* Firefox must shuttle the appropriate data from Firefox Accounts to Sync.

This is similar to #998051, "Re-architect the FxA Sync login to load directly in a tab, not in an iframe in about:accounts"
See Also: → 998051, 1046535
Blocks: 1120706
Blocks: 1150222
No longer blocks: 1120706
Depends on: 1142046
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1150222
You need to log in before you can comment on or make changes to this bug.