Closed Bug 1143703 Opened 8 years ago Closed 7 years ago

emulator-kk fails to start when running Marionette

Categories

(Core :: Storage: IndexedDB, defect)

All
Gonk (Firefox OS)
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: tzimmermann, Unassigned)

References

Details

On emulator-kk I see

> I/Gecko   (   64): [64] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80004005: file ../../../../hg.mozilla.org/mozilla-central/dom/quota/QuotaManager.cpp, line 2327
> I/Gecko   (   64): [64] WARNING: 'NS_FAILED(rv)', file ../../../../hg.mozilla.org/mozilla-central/dom/indexedDB/ActorsParent.cpp, line 11283
> I/Gecko   (   64): [64] WARNING: 'NS_FAILED(rv)', file ../../../../hg.mozilla.org/mozilla-central/dom/indexedDB/ActorsParent.cpp, line 11150
> I/Gecko   (   64): [64] WARNING: Converting non-IndexedDB error code (0x80004005) to NS_ERROR_DOM_INDEXEDDB_UNKNOWN_ERR: file ../../../../hg.mozilla.org/mozilla-central/dom/indexedDB/ActorsParent.cpp, line 406
> W/GeckoConsole(   64): [JavaScript Error: "IndexedDB UnknownErr: ActorsParent.cpp:412"]
> W/GeckoConsole(   64): [JavaScript Error: "UnknownError"]
> I/Gecko   (   64): Activities didn't register correctly!

The STR is

  - run the Marionette tests as described on [1]
  - observe error in logcat

B2G: master
Gecko: 233754:436686833af0

[1] https://developer.mozilla.org/en-US/docs/Mozilla/QA/Marionette/Running_Tests
Summary: Marionette tests fail on emulator-kk → emulator-kk fails to start when running Marionette
See Also: → 1143607
The path for which the Quota manager failed appears to be '/data/local/storage/permanent/chrome'
It looks like the metadata file is missing. Is that an actual file or some magic within the file system?
Oh, it looks like |QuotaManager| tries to open

 /data/local/storage/permanent/chrome.metadata

but what we what is

 /data/local/storage/permanent/chrome/.metadata
(In reply to Thomas Zimmermann [:tzimmermann] [:tdz] from comment #2)
> It looks like the metadata file is missing. Is that an actual file or some
> magic within the file system?

It's a file managed by our quota manager.
Actually, I think you might have found the root cause of a long standing problem.
It seems that marionette tools which pack/unpack files from/to /data/local/storage don't include the metadata file.
See also bug 1094828.
(In reply to Jan Varga [:janv] from comment #4)
> (In reply to Thomas Zimmermann [:tzimmermann] [:tdz] from comment #2)
> > It looks like the metadata file is missing. Is that an actual file or some
> > magic within the file system?
> 
> It's a file managed by our quota manager.
> Actually, I think you might have found the root cause of a long standing
> problem.

Good to hear! One less! :D

> It seems that marionette tools which pack/unpack files from/to
> /data/local/storage don't include the metadata file.
> See also bug 1094828.

I actually found the .metadata file in the directory. Let me test some patches and see what I get.
I run the test scripts on my local builds BTW.
See Also: → 1094828
I'm under the impression we're not going to fix this.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.