Closed Bug 1143725 Opened 8 years ago Closed 8 years ago

First few paragraphs missing from parsed article

Categories

(Toolkit :: Reader Mode, defect, P3)

defect

Tracking

()

RESOLVED FIXED

People

(Reporter: markh, Unassigned)

References

(Blocks 1 open bug, )

Details

+++ This bug was initially created as a clone of Bug #1125711 +++

I'm not sure if it is exactly the same as the above bug, so I created a new one.

In reader view, the first shown paragraph starts with "The Bill would require telecommunications service providers to store so-called “metadata” ..." - this is the 5th paragraph in the article.

Looking at the source, nothing stands out - the missing text is in a <div class="story-body ">, while the test being displayed is in a following <div id="read-more">
Glad you filed anyway, because this still reproduces after our changes to fix some of this. Want to look into this more later today.
Flags: needinfo?(gijskruitbosch+bugs)
This needs algorithm changes to not like the "read more" container so much and/or like another container even more. Leaving needinfo to look into this more.
Fixed in https://github.com/mozilla/readability/pull/50

Landed on fx-team as part of:

https://hg.mozilla.org/integration/fx-team/rev/8a292af9c827

(we've been marking things fixed based on the github status, so I'm closing this).
Status: NEW → RESOLVED
Closed: 8 years ago
Flags: needinfo?(gijskruitbosch+bugs)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.