[masterfirefoxos] [1.4] add new locales

RESOLVED FIXED

Status

Websites Graveyard
Master Firefox OS
RESOLVED FIXED
3 years ago
9 months ago

People

(Reporter: CocoMo, Assigned: jgmize)

Tracking

Details

(Reporter)

Description

3 years ago
Hi Josh,

I need the following added:
Hindi
Tamil
Bengali (for India). 

Bengali for India is a bit tricky as we already have Bengali for Bengladesh. We had talked to the community of consolidating the locales and we were met with strong resistance.  In addition, the "spoken" part of Bengali is very different between Bangladesh and India, so from the perspective of Video demo tips, they need to be different, unless it is subtitling.  

I hope in the directory of language drop-down list, it is clear which one is which.
(Reporter)

Updated

3 years ago
Assignee: nobody → jmize
Summary: [1.4] add new locales → [masterfirefoxos] [1.4] add new locales

Comment 1

3 years ago
Peiying can you add the language codes to this bug. Josh will need that and we want to be sure the locales we enable are the exact ones you reference.
Flags: needinfo?(pmo)
(Reporter)

Comment 2

3 years ago
Hindi - hi-IN
Tamil - ta
Bengali for India - bn-IN

We already have Hindi and Tamil available in 1.1 version.  

In addition, do we have 1.4 audio script available in Amara?
Flags: needinfo?(pmo)
(Reporter)

Comment 3

3 years ago
Also I do not want to assume, do we have English in all the versions of 1.1, 1.3T, 1.3 and 1.4?  We do need 1.4 in English for India launch.

Comment 4

3 years ago
You can check the production site to see what's enabled.

1.1, 1.3, 1.3t and 1.4 are in.

For video -- see email discussion.
(Reporter)

Comment 5

3 years ago
Per email discussion, the video script for voice-over will be done through google doc as it has been done in the past.  For Indic languages, we will have voice over.
(Reporter)

Updated

3 years ago
Blocks: 1145013
(Reporter)

Updated

3 years ago
Blocks: 1145016
(Reporter)

Comment 6

3 years ago
Let's hold off for the moment.  Marketing today informed me that the partner has not firmly decided which version to go.
(Reporter)

Comment 7

3 years ago
Hello Again, it is confirmed that we should go ahead with this request. Please enable it ASAP, hopefully before the weekend so the communities can jump on these right away.

thanks!

Comment 8

3 years ago
Peiying - unfortunately Josh in on pto today and Giorgos is in Europe. We can get to this first thing next week.
(Reporter)

Comment 9

3 years ago
Josh, from what I see now on the test site (as well as the old site), the format is Bengali (Bangladesh).  We can go by Bengali (India).
(Assignee)

Comment 10

3 years ago
(In reply to Peiying Mo [:CocoMo] from comment #9)
> Josh, from what I see now on the test site (as well as the old site), the
> format is Bengali (Bangladesh).  We can go by Bengali (India).

Thanks, I'll update the PR.

Comment 11

3 years ago
Josh - triaging is this all sorted?
Flags: needinfo?(jmize)
(Assignee)

Comment 12

3 years ago
(In reply to Ben (:bensternthal) from comment #11)
> Josh - triaging is this all sorted?

No, I was waiting on a reply from :CocoMo on my question in the PR: https://github.com/mozilla/masterfirefoxos/pull/174#discussion_r27498800 -- I'll be sure to use needinfo for future any questions.
Flags: needinfo?(jmize) → needinfo?(pmo)
(Reporter)

Comment 13

3 years ago
Hi Josh,

Yes, please use the new format indicated in the github comment. Thanks!
Flags: needinfo?(pmo)

Comment 14

3 years ago
Commits pushed to master at https://github.com/mozilla/masterfirefoxos

https://github.com/mozilla/masterfirefoxos/commit/71db925af73eafb1f0e7326b0f7f49f8e2788177
Add 1.4 pending_locales: fix bug 1143800

https://github.com/mozilla/masterfirefoxos/commit/22348249e92f34da103d1f850dc0afee6e38db97
Merge pull request #174 from jgmize/new-1.4-locales

Add 1.4 pending_locales: fix bug 1143800

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED

Comment 15

3 years ago
Peiying - Please be aware that since this is a string change (even though a very small one), we will need localizers to translate this string change.

Josh will update verbatim after which please inform folks of the change.
Flags: needinfo?(pmo)
(Reporter)

Comment 16

3 years ago
Are we adding more strings?  I thought new locales were added to an established version.  

If we are talking about differences between bn-IN and bn-BD, these two repositories are handled by two separate communities.
Flags: needinfo?(pmo)

Comment 17

3 years ago
Peiying... so the above bug had us change Bengali to:

1. Bengali (Bangladesh)
2. Bengali (India)

These strings appear in the dropdown in the locale selection on the site. See https://l10n.masterfirefoxos.com/en/2-0/

So previously folks had translated the string "Bengali" now they need to translate the strings:

1. Bengali (Bangladesh)
2. Bengali (India)

Example of the previous string in po file:
https://github.com/mozilla/masterfirefoxos-l10n/blob/master/de/LC_MESSAGES/django.po#L4738
Flags: needinfo?(pmo)
(Reporter)

Comment 18

3 years ago
Ah yes, got it.  Technically, these two strings are needed in Bengali only, not the other languages.
Flags: needinfo?(pmo)

Comment 19

3 years ago
You are correct!
(Reporter)

Comment 20

3 years ago
Hello Josh,

I thought we have bn-IN branch enabled on github, not just adding a language option on the dropdown menu.  Could you please add 1.4 in bn-IN?  The English strings should be the same as bn-BD.  The bn-IN community would take care of the localization.  Thanks!
Status: RESOLVED → REOPENED
Flags: needinfo?(jmize)
Resolution: FIXED → ---
(Reporter)

Comment 21

3 years ago
Can we have this enabled ASAP?  bn-IN branch is missing

https://github.com/mozilla/masterfirefoxos-l10n

Comment 22

3 years ago
Josh, I know you are swamped but if you can provide an ETA it will help Peiying plan.

Many thanks.
(Assignee)

Comment 23

3 years ago
(In reply to Ben (:bensternthal) from comment #22)
> Josh, I know you are swamped but if you can provide an ETA it will help
> Peiying plan.
> 
> Many thanks.

Apologies for the delay. I should have this resolved tomorrow.
Flags: needinfo?(jmize)
bd-IN generated https://github.com/mozilla/masterfirefoxos-l10n/tree/master/bn_IN/LC_MESSAGES

:mathjazz can you please update verbatim?
Flags: needinfo?(m)
(Reporter)

Comment 25

3 years ago
Verbatim has the bn-IN branch now.  This is fixed.  Thanks!
(Reporter)

Updated

3 years ago
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
Yeah, I've enabled bn-IN in Verbatim.
Flags: needinfo?(m)
Product: Websites → Websites Graveyard
You need to log in before you can comment on or make changes to this bug.