Closed Bug 1143808 Opened 6 years ago Closed 6 years ago

'New contact' button for adding new card still grayed/greyed out/disabled after selecting an addressbook (works after second selection)

Categories

(Thunderbird :: Address Book, defect)

38 Branch
defect
Not set
normal

Tracking

(thunderbird38+ fixed, thunderbird39 fixed)

RESOLVED FIXED
Thunderbird 39.0
Tracking Status
thunderbird38 + fixed
thunderbird39 --- fixed

People

(Reporter: aryx, Assigned: sshagarwal)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

[Tracking Requested - why for this release]:

Thunderbird Daily 39.0a1 20150316 on Windows 8.1

Likely regression from bug 170270: Opening the address book has 'All Address Books' selected. The buttons 'New contact' and 'New list' are disabled. Selecting an address book (e.g. Personal Address Book) only enables 'New List'. Now clicking on the second address book also enables the 'New contant' button which remains enabled when returning to the first address book.
Attached patch Patch v1 (obsolete) — Splinter Review
Attachment #8578164 - Flags: review?(mkmelin+mozilla)
Attachment #8578164 - Flags: feedback?(archaeopteryx)
Comment on attachment 8578164 [details] [diff] [review]
Patch v1

Review of attachment 8578164 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks, seems to work for me.
Attachment #8578164 - Flags: feedback+
Assignee: nobody → syshagarwal
Status: NEW → ASSIGNED
OS: Windows 8.1 → All
Product: MailNews Core → Thunderbird
Hardware: x86 → All
Version: Trunk → 38
Attachment #8578164 - Flags: feedback?(archaeopteryx) → feedback+
Comment on attachment 8578164 [details] [diff] [review]
Patch v1

Review of attachment 8578164 [details] [diff] [review]:
-----------------------------------------------------------------

Yes. 
However, there seems to be be (at least) one case still missing. Once you select and address book and then select a contact only "new list" is enabled.
Attachment #8578164 - Flags: review?(mkmelin+mozilla) → review+
So, new list will create anew list with the selected contact as one of list's contacts. What will new contact do?
Flags: needinfo?(mkmelin+mozilla)
It doesn't. I suppose it could start a new list of the selection if multiple contacts are selected, but afaik it never worked that way. 

For this bug in both cases it should just bring up the new contact/new list dialog, like it did in 31.
Flags: needinfo?(mkmelin+mozilla)
Attached patch Patch v2Splinter Review
Attachment #8578164 - Attachment is obsolete: true
Attachment #8581319 - Flags: review?(mkmelin+mozilla)
Comment on attachment 8581319 [details] [diff] [review]
Patch v2

Review of attachment 8581319 [details] [diff] [review]:
-----------------------------------------------------------------

Thx! r=mkmelin
Attachment #8581319 - Flags: review?(mkmelin+mozilla) → review+
Keywords: checkin-needed
http://hg.mozilla.org/comm-central/rev/998ae30aabe8
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 39.0
You need to log in before you can comment on or make changes to this bug.