Missing "Upcoming Events" section and Mozilla Reps Tweets on dev

RESOLVED FIXED

Status

--
major
RESOLVED FIXED
4 years ago
2 years ago

People

(Reporter: stephend, Unassigned)

Tracking

({regression})

Development/Staging
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [kb=1715442] [fromAutomation], URL)

https://webqa-ci.mozilla.com/view/Mozilla.org/job/mozilla.org.dev.saucelabs/659/testReport/

Thx to Alex for the sleuthing; the following are missing, on dev:

* "Upcoming Events" section
* Mozilla Reps Tweets
It's back. May happen again though.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(In reply to Paul McLanahan [:pmac] from comment #1)
> It's back. May happen again though.

Do we...know why?
Flags: needinfo?(jmize)

Comment 3

4 years ago
There is a race condition between the dev deploy scripts and the cron jobs that write to the db. The dev deploy scripts wipe and re-populate the db every deploy, and cron jobs that attempt to update the db while this is happening can cause this problem. I've filed https://github.com/mozilla/bedrock/pull/2843/ to remove them.
Status: RESOLVED → REOPENED
Flags: needinfo?(jmize)
Resolution: FIXED → ---
https://github.com/mozilla/bedrock/pull/2843 was merged, but listed the wrong bug # (it referenced bug 114384 instead).

Josh, are we good to close this?
This happened again - limited to the Upcoming Events, looks like, so let me know if that should be filed in a separate bug (which I was about to file, but then noticed this):

The "Upcoming Events" section on went missing on https://www-dev.allizom.org, around:

https://webqa-ci.mozilla.com/job/mozilla.org.dev.saucelabs/1050/ (3:49pm PST)
Flags: needinfo?(jmize)
I think we should stop testing these on dev if possible. What is happening is that the dev database is deleted and recreated on every push. If the push isn't able to get the event data from reps for some reason (it does go down from time to time) then that section will go away. This is expected and desired behavior. Since this section can not be counted on for these reasons, I suggest we add a skip for them when running against dev if possible, or just remove the test entirely if we can't. There just isn't a way to make that section reliable on dev.
(In reply to Paul McLanahan [:pmac] from comment #6)
> I think we should stop testing these on dev if possible. What is happening
> is that the dev database is deleted and recreated on every push. If the push
> isn't able to get the event data from reps for some reason (it does go down
> from time to time) then that section will go away. This is expected and
> desired behavior. Since this section can not be counted on for these
> reasons, I suggest we add a skip for them when running against dev if
> possible, or just remove the test entirely if we can't. There just isn't a
> way to make that section reliable on dev.

We can do something like https://github.com/mozilla/Addon-Tests/commit/1663dd938f45e2ee842afa627962f9c4bc15856f#diff-147b19cd946fec500e242f83be6ccfb1L28:

@pytest.mark.skipif('"www-dev.allizom.org" in config.getvalue("base_url")',
- reason='Unreliable cron/feed-fetches from Mozilla Reps on dev')
Perfect. If no one beats me to it I can do that tomorrow.
Whiteboard: [fromAutomation] → [kb=1715442] [fromAutomation]

Comment 9

2 years ago
This was resolved some time ago.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago2 years ago
Flags: needinfo?(jmize)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.