Closed Bug 1143875 Opened 5 years ago Closed 4 years ago

/whatsnew URL: RC 38.0.5 & Developer Editon 40 spring

Categories

(Firefox :: Tours, defect)

36 Branch
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: ckprice, Unassigned)

References

Details

(Whiteboard: engagement-fxGrowth-2015)

We are creating /whatsnew landing pages for RC38 and Developer Edition 40. Both landing on May 12th.

This bug is to ensure that users updating to these versions will be sent to the /whatsnew URL.

This is the first /whatsnew for Developer Edition, so if it should be created in a different bug, please let me know.
Updating to reflect that the URL's will now be required for

FF38.1 (June 2nd)
Dev Edition 40.1 (June 2nd)

There will be no /whatsnew URL needed for May 12th.
Summary: /whatsnew URL: RC 38 & Developer Editon 40 → /whatsnew URL: RC 38.1 & Developer Editon 40.1
Summary: /whatsnew URL: RC 38.1 & Developer Editon 40.1 → /whatsnew URL: RC 38.0.5 & Developer Editon 40.1
:sylvestre - 

Following up on the conversation earlier, just want to make sure we are good here.

/whatsnew RC 38.0.5 (June 2nd)

Only certain locales
VIDEO LOCALES:
en-US, en-GB, de, pt-BR, es-ES, es-MX, fr, ru, ja


/whatsnew dev edition 40.1(?) (June 2nd)

All locales that support /firstrun.

Never have done /whatsnew yet, can you please confirm URL.

Thanks!
Flags: needinfo?(sledru)
Erin, do you know who could answer to Cory's question? thanks
Flags: needinfo?(sledru) → needinfo?(elancaster)
Hmm, btw, I don't think we should call it 40.1 This is confusing and will probably break some tools.
If it is a code name, 40 spring is probably safer.
Jeff Griffiths is the best person to field it.
(In reply to Sylvestre Ledru [:sylvestre] from comment #4)
> Hmm, btw, I don't think we should call it 40.1 This is confusing and will
> probably break some tools.
> If it is a code name, 40 spring is probably safer.

Yah, I think we figured this out a few weeks ago. 40.0 should be the release number unless something changed but Mr. Griffiths can let us know if I'm incorrect.
Flags: needinfo?(elancaster)
Flags: needinfo?(jgriffiths)
The current version number is 40.0a2, fwiw. So it needs to bump to something
> The current version number is 40.0a2, fwiw. So it needs to bump to something
I don't think we can touch the version number itself. We have to find a different way (ex: special UA just for mozilla.org as we did for youtube in bug 1133862).

Some tools are doing assumptions on the version numbers. For the 38.0.5, we bended a lot the workflow and this caused some severe issues (example: no beta for a week). I really don't think we want do that again for 40 (especially that this change would have to be carried for beta and release).
On the devtools team we've been talking about this release as '40.1' so we can logically differentiate it from 40.0. I don't care what the actual version is, whatever works for releng is fine with me.
Flags: needinfo?(jgriffiths)
Summary: /whatsnew URL: RC 38.0.5 & Developer Editon 40.1 → /whatsnew URL: RC 38.0.5 & Developer Editon 40 spring
(In reply to Sylvestre Ledru [:sylvestre] from comment #8)
> > The current version number is 40.0a2, fwiw. So it needs to bump to something
> I don't think we can touch the version number itself. We have to find a
> different way (ex: special UA just for mozilla.org as we did for youtube in
> bug 1133862).

Not sure I really follow, but all mozorg needs to know is what the URL should be, e.g /Firefox/40.0a2/whatsnew/
(In reply to Sylvestre Ledru [:sylvestre] from comment #8)
> I don't think we can touch the version number itself. We have to find a
> different way (ex: special UA just for mozilla.org as we did for youtube in
> bug 1133862).
> 
> Some tools are doing assumptions on the version numbers. For the 38.0.5, we
> bended a lot the workflow and this caused some severe issues (example: no
> beta for a week). I really don't think we want do that again for 40
> (especially that this change would have to be carried for beta and release).
:sylvestre -

We also aren't concerned what the official version number is. Our concern i differentiating users updating/installing on June 2 for whatsnew and firstrun.

The UA option would involve unplanned webdev work.

Would it be possible to send these users to 

/firefox/40.1a2/firstrun/
/firefox/40.1a2/whatsnew/

or maybe

/firefox/40.0.5a2/firstrun/
/firefox/40.0.5a2/whatsnew/

Even if it's just for use in the URL?
Flags: needinfo?(sledru)
What about /firefox/40.0a2-spring/firstrun/ & /firefox/40.0a2-spring/whatsnew/ ?
Flags: needinfo?(sledru)
(In reply to Sylvestre Ledru [:sylvestre] from comment #12)
> What about /firefox/40.0a2-spring/firstrun/ &
> /firefox/40.0a2-spring/whatsnew/ ?
I think this would work! Would let Alex and/or Jon confirm.
Flags: needinfo?(jon)
Flags: needinfo?(agibson)
I'll let Jon decide here as he's working on the dev-edition pages. My first reaction is that this would probably work ok, but it still causes us some irregularity as adding `-spring` means it will fall out of our regular URL scheme handling in bedrock, which might cause a few headaches in the long run. But for a temporary special case it might still be ok.
Flags: needinfo?(agibson)
I guess we could also look to update our regular URL scheme regex to better handle special cases like this. Then we would have an easier means to attach non-version specific keywords like this.
Another option would be something like /firefox/40.0a2/spring/firstrun/
Oh, one more possibility I hadn't considered yet - could we use the current standard /firefox/40.0a2/firstrun/ URL, and then just use waffle to switch the template once this new version is out?
(In reply to Alex Gibson [:agibson] from comment #17)
> Oh, one more possibility I hadn't considered yet - could we use the current
> standard /firefox/40.0a2/firstrun/ URL, and then just use waffle to switch
> the template once this new version is out?

That certainly seems simpler to me.
From an implementation pov
* firstrun needs to be specified in the app, at http://hg.mozilla.org/releases/mozilla-aurora/file/6c5bd5f85e20/browser/branding/aurora/pref/firefox-branding.js#l8
* if it changes we'll need to revert that, no later than the merge to beta on 2015-06-29

* whatsnew we can do in the update server. I'm thinking we will have 'if channel="aurora" and buildID < [some special value, before june 2]: update to a specific build and open a whatsnew. Once users are past that aurora updates will go to the latest build and won't show an whatsnew. We're a little constrained here because the usual mechanism to show a whatsnew is a version change, but I agree with sylvestre that we shouldn't do that.
While we're here discussing updates, can someone please verify that for general release the whatsnew URL is going to be the usual convention?

/firefox/38.0.5/whatsnew/
The following was confirmed in this mornings meeting[0]:

- DevEd locales: all locales we support developer edition.
- DevEd URL: Use existing /firefox/40.0a2/whatsnew(firstrun)/ with a waffle flag for June 2nd. Not concerned with users updating from older files.
- RC locales (bug 1135820): NI sylvestre to confirm disabling /whatsnew outside of this group.
- RC URL (comment 20): standard - /firefox/38.0.5/whatsnew(firstrun)/

[0] 2015-05-26 (whatsnew checkin) https://spring15.etherpad.mozilla.org/development
Flags: needinfo?(jon) → needinfo?(sledru)
(In reply to Cory Price [:ckprice] from comment #21)
> - RC locales (bug 1135820): NI sylvestre to confirm disabling /whatsnew
> outside of this group.
This is not an issue, Releng will take care of that:
https://bugzilla.mozilla.org/show_bug.cgi?id=1157603#c2
Flags: needinfo?(sledru)
To summarize the approach for 40.0a2 /firstrun:

- Through 6/1, users downloading dev edition will be at version 40.0a2 and will see the current template highlighting WebIDE and Valence (visible here: https://www.mozilla.org/en-US/firefox/39.0a2/firstrun/)

- On 6/2, users downloading dev edition will still be at version 40.0a2, but will see a modified template highlighting the new Performance Tools feature and Page Inspector (visible here: https://www-demo5.allizom.org/en-US/firefox/39.0a2/firstrun/)
(In reply to Cory Price [:ckprice] from comment #21)
> The following was confirmed in this mornings meeting[0]:
> 
> - DevEd locales: all locales we support developer edition.
> - DevEd URL: Use existing /firefox/40.0a2/whatsnew(firstrun)/ with a waffle
> flag for June 2nd. Not concerned with users updating from older files.

My suggestion in comment #19 is to avoid getting a whatsnew each time an update is applied (for the life of the promotion). Could you elaborate on what waffle is ? Is it internal to the web server or like a query parameter on the url ?
Waffle is a flag/switch tool for Django:

http://waffle.readthedocs.org/en/latest/

In this case, we're using it to avoid having to do a code push to switch the template served for /firefox/40.0a2/firstrun/ on 6/2. Instead, we just flip a switch to "on" and the template served changes. Here's the relevant code:

https://github.com/mozilla/bedrock/pull/2931/files#diff-784e0d4de42af29595e70315a6be5337R446
Depends on: 1170567
We've shipped dev edition
we're now okay to proceed with bug 1170567 - updated dependency order.
Blocks: 1170567
No longer depends on: 1170567
For RelEng's info - we're pointing at Firefox-mozilla-aurora-whatsnew, which is a copy of Firefox-mozilla-aurora-nightly-latest as of a couple of hours ago. It has 20150603004005 builds for everything except localised win64, which are 20150602163057 instead. The threshold for showing the whatsnew is requests with  buildID '<20150602163057'. As a (very tiny) consequence, anyone who downloaded the 20150602163057 build won't get a whatsnew when they update, but either they got a firstrun (if they are completely new), or they probably read the hacks post otherwise. I think this is not a big deal, and chose to have it shipped already.


(In reply to Hal Wine [:hwine] (use NI) from comment #27)
> we're now okay to proceed with bug 1170567 - updated dependency order.

Maybe wait a bit. We need the majority of people to update over the 20150602163057 watershed before we can remove that.
Please ignore the second part of that, it's bogus.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Does this turn off when 40 moves to beta automatically, or does someone need to do something else?

Thanks.
Flags: needinfo?(jon)
(In reply to Liz Henry (:lizzard) from comment #30)
> Does this turn off when 40 moves to beta automatically, or does someone need
> to do something else?

What's 'this' in this context?
The Aurora whatsnew page is already off in the update server (bug 1172370), and the in-tree patch we needed is backed out (bug 1170567). So we're ready for the merge to beta.
Flags: needinfo?(jon)
You need to log in before you can comment on or make changes to this bug.