If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Remove the padding word from [Stack]BaseShape

RESOLVED DUPLICATE of bug 1143256

Status

()

Core
JavaScript: GC
RESOLVED DUPLICATE of bug 1143256
3 years ago
3 years ago

People

(Reporter: terrence, Unassigned)

Tracking

(Blocks: 2 bugs)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Since the parent removal has landed, we now have a padding word in shape on 32bit. Luke suggested that we get rid of this by moving metadata to a WeakMap.
(Reporter)

Updated

3 years ago
Summary: Remove the padding word from Shape → Remove the padding word from [Stack]BaseShape

Comment 1

3 years ago
Dup of bug 1143256?
(Reporter)

Comment 2

3 years ago
Yup! Thanks.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1143256
You need to log in before you can comment on or make changes to this bug.