SDK Panel flickers while scrolling



Add-on SDK
3 years ago
2 years ago


(Reporter: Nic Luciano, Unassigned)


Firefox Tracking Flags

(Not tracked)



(2 attachments)



3 years ago
Created attachment 8578329 [details]

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_2) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2272.89 Safari/537.36

Steps to reproduce:

1. created a new firefox extension (test case attached as
2. followed the instructions to display a panel
3. tested my extension with cfx run and cfx xpi

Actual results:

if the content of the panel extends beyond it's height, scrolling causes frequent/intense flickering of the panel popup. i've taken a screen recording to demonstrate:>&s=8#.VQdizhDF-6F

Expected results:

it should not flicker when i scroll.

Comment 1

3 years ago
Created attachment 8578330 [details]

Comment 2

3 years ago
sorry- in my original test case i included some unrelated code i added to debug (css hardware acceleration and background colors).

in my experience this code has no affect on the bug, but i've reattached a new test case without that code to help distill the issue.
What versions of Firefox have you tested this with?

Comment 4

3 years ago
hi Dave, thanks. i've only tested on Firefox 36.0.1, Mac OS 10.10.2.

per other flickering-type bugs, i've played with the scrolling & hardware acceleration preferences to no avail.
I see flickering all the way up to Nightly. Not sure what's unique about this case that other panels do not have this
I cannot reproduce this on Linux with the test extension, neither with version 36 nor with Nightly.

Comment 7

3 years ago
thanks again for your help. my colleague confirmed he also experiences the flickering on Mac OS 10.10.2 (Apple hardware), but he does *not* experience the flickering on Windows (using the same Mac with Bootcamp, as well as another HP machine). so it sounds like the issue is exclusive to Mac OS, or Mac OS on a Mac.
To confirm, my tests were all on OSX 10.10 (all failing)
Priority: -- → P2

Comment 9

2 years ago
I'm also having this problem using OS X Yosemite v. 10.10.5 and FireFox 42.0.
You need to log in before you can comment on or make changes to this bug.