Failing Test endOfStream completes previous seek to truncated duration

RESOLVED FIXED in Firefox 38

Status

()

defect
P2
normal
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: jya, Assigned: jya)

Tracking

(Blocks 1 bug)

Trunk
mozilla39
x86
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox37 wontfix, firefox38 fixed, firefox39 fixed)

Details

Attachments

(2 attachments, 2 obsolete attachments)

Assignee

Description

4 years ago
Will fail the webref media-source/mediasource-duration.html with:
TIMEOUT expected FAIL  Test endOfStream completes previous seek to truncated duration

This bug tracks the cause of it.
Assignee

Comment 1

4 years ago
Posted patch Part2. Update webref tests (obsolete) — Splinter Review
update test. We don't pass on linux and webm as we fail an assert to calculate the duration of the video (6.042 vs 6.045)
Attachment #8579130 - Flags: review?(karlt)
Assignee

Updated

4 years ago
Assignee: nobody → jyavenard
Status: NEW → ASSIGNED
Assignee

Comment 2

4 years ago
Comment on attachment 8579130 [details] [diff] [review]
Part2. Update webref tests

wrong bug #
Attachment #8579130 - Attachment is obsolete: true
Attachment #8579130 - Flags: review?(karlt)
Assignee

Updated

4 years ago
Depends on: 1144617
Assignee

Comment 3

4 years ago
Comes out of waiting mode when mediasource is ended. Behaviour was racey. If we decoded all content before EndOfStream() was called we would be stuck in waiting mode forever.
Attachment #8580483 - Flags: review?(matt.woodrow)
Assignee

Comment 4

4 years ago
When seeking to the end of the mediasource duration, we would have stalled as the mPendingSeekTime would never be in the buffered range. So instead, we seek to the last of the audio sample and the last video sample. The MDSM seek logic will hit an end of stream and 
automatically complete the seek as required.
Attachment #8580488 - Flags: review?(matt.woodrow)
Assignee

Comment 5

4 years ago
with bug 1144617 applied, we now pass the test reliably.
Attachment #8580489 - Flags: review?(karlt)
Assignee

Comment 6

4 years ago
Comment on attachment 8580488 [details] [diff] [review]
Part2. Allow seek to end of mediasource.duration

belonged in bug 1144617
Attachment #8580488 - Attachment is obsolete: true
Attachment #8580488 - Flags: review?(matt.woodrow)
Attachment #8580483 - Flags: review?(matt.woodrow) → review+
Attachment #8580489 - Flags: review?(karlt) → review+

Updated

4 years ago
Priority: -- → P2
Assignee

Comment 10

4 years ago
This prevent stalls. And remove the intermittent failure that cause tests to be disabled
Flags: needinfo?(giles)
Comment on attachment 8580483 [details] [diff] [review]
Part1. Come out of waiting mode when mediasource is ended

Approval Request Comment
[Feature/regressing bug #]: MSE
[User impact if declined]: Spec compliance, less consistent testing.
[Describe test coverage new/current, TreeHerder]: Landed on m-c; web platform test.
[Risks and why]: Change is specific to the MSE code. Not trivial, but looks reasonable to me.
[String/UUID change made/needed]: None.
Flags: needinfo?(giles)
Attachment #8580483 - Flags: approval-mozilla-aurora?
Attachment #8580483 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Re-disabled on Windows because it still permafails.
https://hg.mozilla.org/releases/mozilla-aurora/rev/0b7762fb7639
Assignee

Comment 14

4 years ago
the test re-enabled will only pass with bug 1143586 and bug 1142433
Flags: needinfo?(giles)
Flags: needinfo?(giles)
You need to log in before you can comment on or make changes to this bug.