Closed Bug 1143985 Opened 5 years ago Closed 5 years ago

[Flame][First Time Experience] SIM card signal doesn't load successfully on the status bar until user enters the "Geolocation" page.

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.1 wontfix, b2g-v2.1S unaffected, b2g-v2.2 affected, b2g-master unaffected)

RESOLVED DUPLICATE of bug 1145359
blocking-b2g 2.2+
Tracking Status
b2g-v2.1 --- wontfix
b2g-v2.1S --- unaffected
b2g-v2.2 --- affected
b2g-master --- unaffected

People

(Reporter: lixia, Assigned: mikehenrty)

References

Details

(Keywords: regression, Whiteboard: [systemsfe])

Attachments

(6 files)

[1.Description]:
[Flame][v2.1&2.2][First Time Experience]SIM card signal doesn‘t load successfully on the status bar until user enters the "Geolocation" page after "Select a network" page in FTU.
Found time:15:54
Attach:SIM2_signal.mp4 ,contrast.png and logcat_1554.txt.

[2.Testing Steps]: 
1.Insert a or two SIM card and must enable PIN1 code.
2.Flash build.
3.Enter FTU,tap "Next" and input correct PIN1 code.
4.Wait for some minutes.
5.Tap "Next" on "Cellular Data" page,then tap "Next" on "Select a network" page.
**It will enter the "Geolocation" page.

[3.Expected Result]: 
4. SIM card signal loads successfully after user enters PIN1 code, rather than waiting until user enters the "Geolocation" page in FTU.

[4.Actual Result]: 
4&5. SIM card signal does not load successfully until user enters the "Geolocation" page after "Select a network" page.

[5.Reproduction build]: 
Flame 2.2 (affected):
Build ID               20150316162504
Gaia Revision          d0e09d5e6367e558824f9cbf691da99cedf63037
Gaia Date              2015-03-16 17:14:22
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/793d61bb0bd4
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150316.195035
Firmware Date          Mon Mar 16 19:50:48 EDT 2015
Bootloader             L1TC000118D0

Flame 2.1 (affected):
Build ID               20150316161200
Gaia Revision          e53469fe3a5e563a9146d0fb028e544a423b7e96
Gaia Date              2015-03-16 15:30:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/32d1cae787e0
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150316.192737
Firmware Date          Mon Mar 16 19:27:48 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 (unaffected):
Build ID               20150316160204
Gaia Revision          4868c56c0a3b7a1e51d55b24457e44a7709ea1ae
Gaia Date              2015-03-14 18:50:17
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/436686833af0
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150316.193248
Firmware Date          Mon Mar 16 19:32:58 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test

[8.Note]
1.On Flame v2.1, SIM card signal doesn't load successfully until user enters the "Select a network" page after "Cellular Data" page.
2.On Flame v2.0,it doesn't display the status bar in FTU.
See Also: → 1062998
Attached image contrast.png
Attached file logcat_1554.txt
Attached video SIM2_signal.mp4
I can't repro this bug on v2.1S,SIM card signal displays on status bar once user enters PIN1 code in FTU.

2.1S_512mb (unaffected):
Build ID               20150316001202
Gaia Revision          88bd440e58a1584d065c29cf7a3450d25e45017b
Gaia Date              2015-03-12 02:49:16
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1s/rev/d4bb54313129
Gecko Version          34.0
Device Name            scx15_sp7715ea
Firmware(Release)      4.4.2
Firmware(Incremental)  122
Firmware Date          Thu Feb  5 12:42:58 CST 2015
Hi Shally, How is the reception in there? Possible to try that in a place with really good signal?
Flags: needinfo?(lixia)
Hi Eric,

    I still can repro this bug in the place with really good signal. No matter how long I've waited for searching and loading signal.
Flags: needinfo?(lixia) → needinfo?(echang)
[Blocking Requested - why for this release]:
Set 2.2? for better user experience.
blocking-b2g: --- → 2.2?
Flags: needinfo?(echang)
Can we get a reverse regression window?
Keywords: qawanted
QA Contact: ychung
b2g-inbound Regression Window:

Last Broken Environmental Variables:
Device: Flame 3.0
BuildID: 20150303023847
Gaia: 6036295b7192e21c1370495617e5ab727575fea3
Gecko: 97c49ccbdfbf
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

First Working Environmental Variables:
Device: Flame 3.0
BuildID: 20150303025447
Gaia: d9399ecd386aaf37214c4bffcaceca335c143413
Gecko: 11a4ffbd9ee9
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Last Broken Gaia First Working Gecko: Issue DOES reproduce 
Gaia: 6036295b7192e21c1370495617e5ab727575fea3
Gecko: 11a4ffbd9ee9

First Working Gaia Last Broken Gecko: Issue does NOT reproduce
Gaia: d9399ecd386aaf37214c4bffcaceca335c143413
Gecko: 97c49ccbdfbf

https://github.com/mozilla-b2g/gaia/compare/6036295b7192e21c1370495617e5ab727575fea3...d9399ecd386aaf37214c4bffcaceca335c143413

Possibly fixed by bug 1098168
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Contact: ychung
Alive, can you take a look at this please? Can the work done for bug 1098168 be uplifted to 2.2?
Blocks: 1098168
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(alive)
Taken, thanks.
Assignee: nobody → alive
Component: Gaia::First Time Experience → Gaia::System
Flags: needinfo?(alive)
I misunderstood the bug - sorry.
Bug 1098168 is too big and still has some followup - we should not uplift but only try to understand what's fixed that.

Michael, could you track this bug in your team? Thanks.
Assignee: alive → nobody
Flags: needinfo?(mhenretty)
Whiteboard: [systemsfe]
I think this might be fixed by bug 1145359. Let's wait til that lands on 2.2 and retest.
Assignee: nobody → mhenretty
Depends on: 1145359
Flags: needinfo?(mhenretty)
confirmed blocker for poor experience
blocking-b2g: 2.2? → 2.2+
I just tried to repro with bug 1145359 landed on 2.2, and I couldn't reproduce anymore. I'm marking as duplicate, but also added a verifyme to test on 2.2 with the patch from bug 1145359.
Status: NEW → RESOLVED
Closed: 5 years ago
Keywords: verifyme
Resolution: --- → DUPLICATE
Duplicate of bug: 1145359
Depends on: 1151502
Hi Michael,

    Inserting one or two SIM cards (CMCC or CU),I also can't repro this bug on latest Flame v2.2 (Rate:0/8). 

    But there is a different results on latest Flame v2.1:
    (1) Inserting a CU SIM card in device (I use four different CU SIM cards to test),the SIM1 (or SIM2) card signal doesn't load successfully until user enters the "Select a network" page after "Cellular Data" page.  (Rate:8/8)
     -->Fail,please refer attachments, thanks.

    (2) Inserting two CU SIM cards in device,the SIM1 and SIM2 signals can load successfully on "SIM manager" page.  -->Pass
    (3) Inserting a CMCC SIM card in device,the SIM1 (or SIM2) card signal can load successfully on "Cellular Data" page.  -->Pass

-------------------------------------------------------------------------------------------------
Device: Flame 2.1 build(Fail)
Build ID               20150420001205
Gaia Revision          bbe983b4e8bebfec26b3726b79568a22d667223c
Gaia Date              2015-04-09 13:52:48
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/b85d4f4a6d61
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150420.035930
Firmware Date          Mon Apr 20 03:59:40 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 2.2 build(Pass)
Build ID               20150420002502
Gaia Revision          c15a2b6d3a783813959c2b3bffd2a131f4270b9e
Gaia Date              2015-04-17 17:49:32
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/cc02ee38b252
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150420.041634
Firmware Date          Mon Apr 20 04:16:45 EDT 2015
Bootloader             L1TC000118D0
Flags: needinfo?(mhenretty)
Attached video verify_v2.1.mp4
Attached video verified_v2.2.mp4
Thanks Shally. You are correct, the code for bug 1145359 was never uplifted to master.

ni? kevin to see if he wants this on 2.1 as well. I'm marking as wontfix for now.
Flags: needinfo?(mhenretty) → needinfo?(khu)
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
Thanks, Michael. 

Based on comment 4, it can't reproduced on 2.1S, and this bug also doesn't look like something we need for Stingray, I think we are good to not have this in 2.1.
Flags: needinfo?(khu)
Per Comment 15 and Comment 16,this bug can't be repro anymore on Flame v2.2.
And per Comment 20 and Comment 21,clear "verifyme" keywords.
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.