Closed Bug 1144033 Opened 7 years ago Closed 4 years ago

[Nexus-5][gonk-l] Device stayed at Firefox OS screen and cannot boot up to home.

Categories

(Firefox OS Graveyard :: General, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: dliang, Unassigned)

Details

Attachments

(2 files)

Attached file n5-hang.tar.gz
Device stayed at Firefox OS screen and cannot boot up to home.
Adb works and we lots of error message about cpu bring up fail:
<4>[17670.785996] _cpu_up: attempt to bring up CPU 1 failed
<4>[17670.787119] _cpu_up: attempt to bring up CPU 2 failed
<4>[17670.788084] _cpu_up: attempt to bring up CPU 3 failed
<4>[17670.836968] _cpu_up: attempt to bring up CPU 1 failed
<4>[17670.837878] _cpu_up: attempt to bring up CPU 2 failed
<4>[17670.838821] _cpu_up: attempt to bring up CPU 3 failed
<4>[17670.885997] _cpu_up: attempt to bring up CPU 1 failed
<4>[17670.887115] _cpu_up: attempt to bring up CPU 2 failed
<4>[17670.888082] _cpu_up: attempt to bring up CPU 3 failed

SW information:
Build ID               20150316002502
Gaia Revision          a6b2d3f8478ec250beb49950fecbb8a16465ff6f
Gaia Date              2015-03-15 14:33:22
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/18619f8f6c5c
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150316.042754
Firmware Date          Mon Mar 16 04:28:10 EDT 2015
Bootloader             HHZ12d
Attached file n5-hang-0318.tar.gz
Attachment include dmesg, logcat and b2g-info. This time we didn't see the message about cpu bring up fail. dmesg looks normal and logcat is full of following logs:
1463 03-18 01:25:37.194 D/QSEECOMD: ( 4330): qseecom listener services process entry PPID = 1
1464 03-18 01:25:37.194 E/QSEECOMD: ( 4330): Listener: index = 0, hierarchy = 0
1465 03-18 01:25:37.194 E/QSEECOMD: ( 4330): Init dlopen(librpmb.so, RLTD_NOW) is failed....
1466 03-18 01:25:37.194 E/QSEECOMD: ( 4330): ERROR: RPMB_INIT failed, shall not start listener services
=> It should not be the root cause due to we can still see this error at normal boot up.

1467 03-18 01:25:37.663 E/HWComposer(  953): Non-uniform vsync interval: 265591197
1468 03-18 01:25:38.161 E/HWComposer(  953): Non-uniform vsync interval: 298761041
1469 03-18 01:25:38.659 E/HWComposer(  953): Non-uniform vsync interval: 298805001
=> under checking

1470 03-18 01:25:38.701 E/sdcard  (  205): missing packages.list; retrying
=> It is not root cause of this problem.
Hi Paul,
Could you provide more information include test environment and STR of this bug?
Thanks,
Flags: needinfo?(pyang)
1. clone https://github.com/Mozilla-TWQA/mtbf_operation
2. make vmaster
3. source mtbf-env/bin/activate
4. install latest gaiatest in gaia/tests/python/gaia-ui-tests
5. run "mtbf_job_runner.py" specify a valid testvars.json
Flags: needinfo?(pyang)
After check, it doesn't relate to db corrupt and b2g processes existed.
By discussing with Danny, the issue seems gone when disabling Hwc. ni? by myself to keep tracking.
Flags: needinfo?(vliu)
Sotaro, Mason, there seems to be an issue with HWC on lollipop recently.  Could you take a look?
Flags: needinfo?(sotaro.ikeda.g)
Flags: needinfo?(mchang)
Unfortunately, I don't have an L device.
Flags: needinfo?(mchang)
But Silk is enabled by default on master, which means if HwC is broken and we don't get vsync notifications, then we won't composite anything, so we won't see anything on the screen. But we should check that we can enable vsync notifications and fallback to software vsync if enabling vsync fails. This would explain comment 6.
Hi Paul,

I flash my Nexus 5 with PVT rom build (branch: 2.2 build ID: 20150318162504).
Cannot reproduce the issue. (0/5 times)
Could you help run the auto test with this build also?

Munro
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #7)
> Sotaro, Mason, there seems to be an issue with HWC on lollipop recently. 
> Could you take a look?

attachment 8578502 [details] and attachment 8579090 [details] have the following log. I sometimes build nexus-5-l, but I did not saw such log in the past. I suspect that the ROM build might not be correctly done.

------------------------------------
03-18 01:25:32.138 D/QSEECOMD: ( 4328): qseecom listener services process entry PPID = 1
03-18 01:25:32.138 E/QSEECOMD: ( 4328): Listener: index = 0, hierarchy = 0
03-18 01:25:32.138 E/QSEECOMD: ( 4328): Init dlopen(librpmb.so, RLTD_NOW) is failed....
03-18 01:25:32.138 E/QSEECOMD: ( 4328): ERROR: RPMB_INIT failed, shall not start listener services
Flags: needinfo?(sotaro.ikeda.g)
I crated a latest v2.2 nexus-5-l ROM from latest v2.2 source code. By applying the ROM, the nexus-5 booted normally.
Hi Paul,

Do you still see this issue happens?
Flags: needinfo?(pyang)
Yes, we have encountered this issue yesterday.
Flags: needinfo?(pyang)
Flags: needinfo?(vliu)
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.