[Flame][Task Manager] User can switch recent apps in the background in confirm install app view.

VERIFIED FIXED in 2.2 S8 (20mar)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: yulan.zhu, Assigned: etienne)

Tracking

unspecified
2.2 S8 (20mar)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(6 attachments)

(Reporter)

Description

4 years ago
Posted file log.txt
[1.Description]:
[Flame][v2.2&v3.0][Task Manager]User can switch between recent apps in the background in comfirm install app view.
See attachments:Video.mp4 and log.txt
Occurrence time:15:33

[2.Testing Steps]: 
1.Run some apps in the background.
2.Connect the network and launch Marketplace.
3.Select an app to download.
4.Slide from left/ right edge to right/ left.

[3.Expected Result]: 
4.User cannot switch recent apps in the background.

[4.Actual Result]: 
4.You can switch recent apps in the backgroud.

[5.Reproduction build]: 
Flame 2.2 build (Affected):
Build ID               20150316162504
Gaia Revision          d0e09d5e6367e558824f9cbf691da99cedf63037
Gaia Date              2015-03-16 17:14:22
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/793d61bb0bd4
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150316.195035
Firmware Date          Mon Mar 16 19:50:48 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 build(Affected):
Build ID               20150316160204
Gaia Revision          4868c56c0a3b7a1e51d55b24457e44a7709ea1ae
Gaia Date              2015-03-14 18:50:17
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/436686833af0
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150316.193248
Firmware Date          Mon Mar 16 19:32:58 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,10/10

[7.TCID]: 
Free Test

[8.Note]:
Open Notifications and select Settings button, Settings will be launched in the background.
(Reporter)

Comment 1

4 years ago
Posted video Video.mp4
blocking-b2g: --- → 2.2+
Etienne, Alive, can you take a look?
Flags: needinfo?(etienne)
Flags: needinfo?(alive)
Etienne, if you are occupied I could take it. Simple fix I think.
Flags: needinfo?(alive)

Updated

4 years ago
Whiteboard: [systemsfe]
(Assignee)

Comment 4

4 years ago
(In reply to Alive Kuo [:alive][NEEDINFO!] from comment #3)
> Etienne, if you are occupied I could take it. Simple fix I think.

I'll send you the review :)
Assignee: nobody → etienne
Flags: needinfo?(etienne)
(Assignee)

Comment 6

4 years ago
Comment on attachment 8579282 [details] [review]
[gaia] etiennesegonzac:1144054 > mozilla-b2g:master

Here we go :)
Attachment #8579282 - Flags: review?(alive)
Comment on attachment 8579282 [details] [review]
[gaia] etiennesegonzac:1144054 > mozilla-b2g:master

so fast!
Attachment #8579282 - Flags: review?(alive) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Since it is a 2.2 blocker, could you please also uplift to v2.2? Thanks. ;)
Keywords: verifyme
(Assignee)

Comment 10

4 years ago
Comment on attachment 8579282 [details] [review]
[gaia] etiennesegonzac:1144054 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): the initial edge gesture landing
[User impact] if declined: see Description
[Testing completed]: edge gestures scenarios,  edge swiping during install and install cancellation
[Risk to taking this patch] (and alternatives if risky): low (simple patch with lots of tests)
[String changes made]: none
Attachment #8579282 - Flags: approval-gaia-v2.2?
Attachment #8579282 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Needs rebasing for v2.2 uplift.
Flags: needinfo?(etienne)
Target Milestone: --- → 2.2 S8 (20mar)
This bug has been failed verified on latest Flame v3.0. The edge gesture and edge swiping does not work on install app view and install cancellation view. 
I will file a following up bug soon.
See attachments: verify_v3.0.MP4
Reproduce rate: 5/5

Device: Flame 3.0 (Fail)
Build ID               20150324160206
Gaia Revision          aebfbd998041e960cea0468533c0b5041b504850
Gaia Date              2015-03-24 17:08:51
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/264387e7e453
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150324.193523
Firmware Date          Tue Mar 24 19:35:34 EDT 2015
Bootloader             L1TC000118D0
I am so sorry to misunderstand this bug,please ignore Comment 12,thanks
According to the STR of Comment 0,this bug has been successfully verified on latest Flame v3.0. The edge gesture and edge swiping will not work on install app view and install cancellation view as expected. 
See attachment: verify_v3.0.
Reproduce rate: 0/5

Device: Flame 3.0 (Pass)
Build ID               20150324160206
Gaia Revision          aebfbd998041e960cea0468533c0b5041b504850
Gaia Date              2015-03-24 17:08:51
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/264387e7e453
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150324.193523
Firmware Date          Tue Mar 24 19:35:34 EDT 2015
Bootloader             L1TC000118D0

Leaving "verifyme" keyword for Flame v2.2 uplift.
(Assignee)

Comment 16

4 years ago
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #11)
> Needs rebasing for v2.2 uplift.

I think we should uplift bug 1097296 first instead of doing a specific 2.2 patch (just asked for 2.2+ on the other bug).
Flags: needinfo?(etienne)
NI myself for following 2.2 verification.
Flags: needinfo?(hcheng)
Lancy, could you please verify this bug? Thanks.
Flags: needinfo?(hcheng) → needinfo?(yulan.zhu)
Hi Hermaes,

    Sync with reporter,this bug has been failed verified on latest Nightly Flame v2.2&3.0 by the following steps. 
    
Actual Results: Can switch recent apps in the background on install app view and install cancellation view.

See attachments: verify_v2.2&3.0.MP4 and new_logcat_1712.txt
Reproduce rate: 5/5

Repro STR:
1.Run some apps in the background.
2.Launch Marketplace.
3.Select an app to download.
4.Slide from left/ right edge to right/ left.
**Can not switch these recent apps in the background. --OK

The different steps:
5.Long tap Home button.
6.Select and tap an app on card view.
7.When returning "install app" view,slide from left/ right edge to right/ left.
**Can switch these recent apps in the background showing on the notification bar.--KO


Device: Flame 2.2 build(Fail)
Build ID               20150326164141
Gaia Revision          6d0174e28576f2f93e696a43d1ac3b03340117f6
Gaia Date              2015-03-26 21:47:33
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/820c2f2e817a
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150326.201153
Firmware Date          Thu Mar 26 20:12:05 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 build(Fail)
Build ID               20150326160206
Gaia Revision          525c341254e08f07f90da57a4d1cd5971a3cc668
Gaia Date              2015-03-26 16:34:16
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/59554288b4eb
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150326.193247
Firmware Date          Thu Mar 26 19:32:58 EDT 2015
Bootloader             L1TC000118D0
Flags: needinfo?(yulan.zhu) → needinfo?(hcheng)
Shally, I think this is another issue.

The original issue is that the user can switch application when he/she sliding left/right at "Install" dialog of Marketplace.

However, at comment 20, you used Task Manager to close Marketplace but the "Install" dialog still existed. Then, the app can be switched by sliding. The problem is why the dialog is still there. Please open another bug for it. 

Besides, if the original steps is passed, please close this bug. Thanks.
Flags: needinfo?(hcheng) → needinfo?(lixia)
Ok,I will submit it soon,thanks.
Flags: needinfo?(lixia)
Per Comment 15 & Comment 20 & Comment 23, this bug has been successfully verified on latest Nightly Flame v3.0&2.2. 

Actual Results: Can not switch these recent apps of the background on install app view and install cancellation view as expected. 
(Please see attachment: verify_v3.0.mp4)
Status: RESOLVED → VERIFIED
Keywords: verifyme
See Also: → 1148733
The another bug is bug 1148733.
You need to log in before you can comment on or make changes to this bug.