Closed Bug 1144099 Opened 7 years ago Closed 7 years ago

Making Firefox the default browser does also enable the checkbox for "Always check if Firefox is your default browser"

Categories

(Firefox :: Preferences, defect)

36 Branch
x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED INVALID

People

(Reporter: sworddragon2, Unassigned)

References

Details

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150306140302

Steps to reproduce:

1. Make sure Firefox is not your default browser.
2. Start Firefox and go to the menu bar -> Edit -> Preferences -> General.
3. If it is enabled disable "Always check if Firefox is your default browser".
4. Click on "Make Default".


Actual results:

The checkbox for "Always check if Firefox is your default browser" got enabled.


Expected results:

The checkbox for "Always check if Firefox is your default browser" should not get enabled.
I can reproduce it in nightly, but I don't think it's a bug. Shouldn't it be like that?
I don't think so as the user requested just to set Firefox now as the default browser and not to check always for it. In my opinion it isn't here very clean to set 2 options while the user requested only one.
I can reproduce it in nightly version 39.0a1 but I also don't think that it's a bug.
I think it's because if you chose it to be the default browser, you want it to stay default.  If another program becomes the default later, it may have not been your intention (for example, an accidental agreement to another browser's question).
Blocks: 1040868
QA Whiteboard: [bugday-20150323]
Component: Untriaged → Preferences
Indeed - this is intentional behavior per bug 1041516.
No longer blocks: 1040868
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.