Nightly suffers performance hit after display sleep on OSX.

RESOLVED DUPLICATE of bug 1142957

Status

()

Core
General
RESOLVED DUPLICATE of bug 1142957
3 years ago
3 years ago

People

(Reporter: mhoye, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
On Nightly/OSX 39.0a1 (2015-03-16)

If I let the display sleep (but not lock) and then wake it up again, Nightly becomes almost completely unresponsive. Menus continue to be actionable, but tabs and in-browser events take 30+ seconds to register or display changes. Nothing out of the ordinary shows up in the console when this happens, but the browser is completely off in the weeds.

The effect goes away after about two minutes, and things return to normal snappiness. 

I can reliably duplicate this.

Comment 1

3 years ago
I've seen this as well on Mavericks.

Comment 2

3 years ago
Also, it felt to me like painting was just broken vs CPU usage, etc.  Maybe vsync related changes?  Has that landed in Mac?
Should be fixed in today's nightly...
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1142957
Or rather tomorrow's apparently.
You need to log in before you can comment on or make changes to this bug.