Log utility tray events behind a pref to debug status bar freezing

RESOLVED WONTFIX

Status

Firefox OS
Gaia::System
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: gmarty, Assigned: gmarty)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [systemsfe])

Attachments

(2 attachments)

(Assignee)

Description

3 years ago
To fix the problem of the status bar freezing under random circumstances, we'll do the following:

* Log detais to the SD card such as:
  * The utility tray opening/closing events
  * The value of StatusBar._paused
  * Anything we can think of and that can be related to this issue
* This log will be enable via a pref
* Tell dogfooder to activate this setting
(Assignee)

Updated

3 years ago
Whiteboard: [systemsfe]
(Assignee)

Updated

3 years ago
Blocks: 1139470
FWIW I added such logs in my dogfooding 2.1 build but couldn't reproduce since I'm back next to a computer.
(Assignee)

Comment 3

3 years ago
On hold till the patch for Bug 1139470 lands.
(Assignee)

Updated

3 years ago
Assignee: nobody → gmarty
Guillaume, can we finish this off? It looks like bug 1154635 is still happening even after our latest statusbar sync fix, so we should get the logs on the person's device who can reproduce this.
Flags: needinfo?(gmarty)
Since blocking bug 1154635 which is a 2.2 blocker, nom tihs one, too.
Blocks: 1154635
blocking-b2g: --- → 2.2?
(Assignee)

Comment 6

3 years ago
Let's wait for a few days after Bug 1154800 lands and see if working on this bug is still needed.
Flags: needinfo?(gmarty)
Not blocking. Request uplift approval if needed to fix dependent bug.
blocking-b2g: 2.2? → ---
Created attachment 8604668 [details] [review]
[gaia] gmarty:Bug-1144126-Log-utility-tray-events-behind-a-pref-to-debug-status-bar-freezing > mozilla-b2g:master
(Assignee)

Comment 9

3 years ago
Created attachment 8604671 [details] [review]
Github PR

This patch logs interesting events and values when enabled.
To enable it, create a new settings called `statusbar.log-events.enabled` and set it to true.

When deactivated, it should not impact performance.
Attachment #8604671 - Flags: review?(etienne)
Comment on attachment 8604671 [details] [review]
Github PR

sounds good, r=me minus the file header change

2 suggestions:
- please contribute any idea on how to generalize this to https://groups.google.com/forum/#!topic/mozilla.dev.gaia/5gfXlJUhWJo

- if this is aimed at dogfooders we should add a way to turn on the setting in the developer settings pane (there's already a "Debug" category).

Cheers!
Attachment #8604671 - Flags: review?(etienne) → review+
(Assignee)

Comment 11

3 years ago
With the revamp of the status bar in 2.5, this patch is not used anymore. Let's close this bug.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.