Option to choose to always show the "Restore Session" tab or to automatically restoring the previous session

RESOLVED WORKSFORME

Status

()

Firefox
Session Restore
--
enhancement
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: sworddragon2, Unassigned)

Tracking

36 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150306140302

Steps to reproduce:

1. Open any site (for example this bug report).
2. Cause Firefox to crash and start it again.


Actual results:

Sometimes Firefox does automatically restore all previous tabs and sometimes it opens the "Restore Session" tab instead.


Expected results:

Maybe there could be an option in about:config to always use only one of these both methods.
(Reporter)

Updated

3 years ago
Severity: normal → enhancement

Updated

3 years ago
Component: Untriaged → Session Restore

Comment 1

3 years ago
// number of crashes that can occur before the about:sessionrestore page is displayed
// (this pref has no effect if more than 6 hours have passed since the last crash)
pref("browser.sessionstore.max_resumed_crashes", 1);

I have it set to 0, so I always get the "Restore Session" tab. You can set it to a higher value if you want it to appear less, but don't set it so high that you might get stuck in a restart-crash loop!

I'm not sure why the cutoff is [6 hours]. I would have expected [5 minutes] or [1 minute after Firefox finishes restoring pinned & active tabs]. The cutoff was chosen in bug 448976, and indeed Simon worried about the confusion it might cause. It would be reasonable to file a (separate) bug asking to change the cutoff and/or make the cutoff also be a pref.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.