Closed Bug 1144191 Opened 5 years ago Closed 5 years ago

Impossible to seek in MP4 videos with Apple QT extension after bug 1130450 landed

Categories

(Core :: Audio/Video, defect)

37 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED INVALID
Tracking Status
firefox36 --- unaffected
firefox37 - wontfix
firefox38 - ---
firefox39 - ---

People

(Reporter: epinal99-bugzilla2, Assigned: jya)

References

Details

(Keywords: regression)

Reported by QA here: https://bugzilla.mozilla.org/show_bug.cgi?id=1130450#c26

STR:
1) Open the testcase https://bugzilla.mozilla.org/attachment.cgi?id=8565686
2) Try to seek during the playback

Result: impossible to seek (back or forward).
Broken after bug 1130450 landed.
[Tracking Requested - why for this release]: recent regression
Blocks: 1130450
Flags: needinfo?(jyavenard)
Keywords: regression
Jean-Yves, we're a couple of betas away from RC - what are the options here?  Can you identify a fix?  What's the user impact of backing out 1130450 vs. shipping this regression?
If you back out bug 1130450, these specific MP4s will be not decoded anymore due to a previous regression fixed by bug 1130450. So broken seeking has probably less impact.
How can this be a regression when the video wouldn't have even started or played previously?
I will have a look
Flags: needinfo?(jyavenard)
Bug 1057879 broke the playback of MP4s with Apple QT extension (no decoding).
Bug 1130450 has fixed this regression, but incompletely: the playback works again but seeking is broken.
This current bug is about broken seeking.
Summary: Impossible to seek in MP4 videos with Apple Apple QT extension after bug 1130450 landed → Impossible to seek in MP4 videos with Apple QT extension after bug 1130450 landed
Blocks: 1057879
Jean-Yves - Did you have a chance to look into this?

For 37, I tend to agree that the situation has improved even though it it still not working as expected. As we're very late in the 37 cycle, I'm marking this as wontfix for 37.
Flags: needinfo?(jyavenard)
Assignee: nobody → jyavenard
Flags: needinfo?(jyavenard)
will work on this today.. hopefully won't take long
You simply can't seek here because bugzilla.mozilla.org doesn't support range request  

Let the video fully buffer, and then you'll be able to seek.

Or host the file to another server that does support range request
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → INVALID
BTW, exactly same behaviour with chrome
Untracking since this appears not to be a bug.
You need to log in before you can comment on or make changes to this bug.