Closed Bug 1144224 Opened 8 years ago Closed 8 years ago

[Video app] crash in @0x0 | android::GraphicBuffer::lockYCbCr(unsigned int, android::Rect const&, android_ycbcr*)

Categories

(Firefox OS Graveyard :: Gaia::Video, defect)

All
Android
defect
Not set
critical

Tracking

(firefox37 unaffected, firefox38 unaffected, firefox39 fixed, b2g-v2.2 unaffected, b2g-master fixed)

VERIFIED FIXED
2.2 S8 (20mar)
Tracking Status
firefox37 --- unaffected
firefox38 --- unaffected
firefox39 --- fixed
b2g-v2.2 --- unaffected
b2g-master --- fixed

People

(Reporter: pcheng, Assigned: mwu)

References

Details

(4 keywords, Whiteboard: [3.0-Daily-Testing][fromAutomation])

Crash Data

This bug was filed from the Socorro interface and is 
report bp-15ffeba1-b5bc-4976-be7a-016032150317.
=============================================================

The video app is crashing 5 out of 5 attempts in latest tinderbox Central build. On today's nightly it is NOT crashing, perhaps the culprit has not landed on nightly.

Prerequisite:
Have at least one video on the device

STR:
Open Video app

Expected: Video app loads properly

Actual: Video app crashes while loading

Tested on:
Device: Flame 3.0 Master (tinderbox eng build, KK, 319MB mem)
BuildID: 20150317034728
Gaia: 738987bd80b0ddb4ccf853855388c2627e19dcc1
Gecko: 008b3f65a7e0
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Contact: pcheng
ni?ing milan since it looks like a gecko issue.
Flags: needinfo?(milan)
Bug 1120780  might be related to the regression.
Keywords: smoketest
Whiteboard: [3.0-Daily-Testing]
I am going to check if Comment 2 is correct.
Comment 2 is correct.

b2g-inbound regression window:

Last Working Environmental Variables:
Device: Flame 3.0 Master
BuildID: 20150316182555
Gaia: 1a1361af15ca0f7b5cf8d28b1f1de619eed0562e
Gecko: 66536ec0d8f6
Version: 39.0a1 (3.0 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

First Broken Environmental Variables:
Device: Flame 3.0 Master
BuildID: 20150316183931
Gaia: 1a1361af15ca0f7b5cf8d28b1f1de619eed0562e
Gecko: e86c7b372d7a
Version: 39.0a1 (3.0 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Gaia is the same so it's a Gecko issue.

Gecko pushlog:
http://hg.mozilla.org/integration/b2g-inbound/pushloghtml?fromchange=66536ec0d8f6&tochange=e86c7b372d7a
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Michael, can you take a look at this please? Can we get the landing for bug 1120780 backed out?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(mwu)
Also ni?ing sotaro for backout request as well
Flags: needinfo?(milan) → needinfo?(sotaro.ikeda.g)
It was backed out in bug 1120780.
Flags: needinfo?(sotaro.ikeda.g)
Flags: needinfo?(mwu)
Infrastructure failures with hg.mozilla.org stopped me from merging the backout over to m-c in time for the 4pm nightlies. (Though I guess the hg.m.o issues would likely break the nightlies entirely, so no still-broken nightlies would be pushed out.)
https://hg.mozilla.org/mozilla-central/rev/2fb7a59b725e
Assignee: nobody → ryanvm
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Assignee: ryanvm → mwu
Target Milestone: --- → 2.2 S8 (20mar)
This issue is verified fixed on Flame 3.0

The video app opens to list view on launch, and videos can be viewed without the app crashing

Environmental Variables:
Device: Flame 3.0 (319mb)(Kitkat)(Full Flash)
Build ID: 20150318010207
Gaia: 647c9c649965d5a14f32f7d09f4eacc2a9f2136e
Gecko: 1174ffb1696d
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Based on the automation report sent that day, this issue was caught by the gaia end-to-end tests.
Whiteboard: [3.0-Daily-Testing] → [3.0-Daily-Testing][fromAutomation]
You need to log in before you can comment on or make changes to this bug.