Closed Bug 1144233 Opened 5 years ago Closed 5 years ago

Recipient autocomplete considers last mouse-hovered contact from results dropdown "selected" and then uses that upon blur (e.g. when moving to subject)

Categories

(Thunderbird :: Message Compose Window, defect, critical)

x86_64
Windows 7
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1152517

People

(Reporter: jason.austin, Unassigned)

Details

(Keywords: dataloss, privacy, regression)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2272.89 Safari/537.36

Steps to reproduce:

In addressing an email, I would type in the first few letters of the recipient's name until their name and email address were highlighted at he top of a drop down box from the address book.   With no further action I would then move the cursor down to the subject line or message box and continue with the email, and that highlighted name would be shown as the recipient.  


Actual results:

Some time in the last few weeks there has been a change.  Now, after finding the recipient from the address book, when the cursor is moved to the subject line or email body, the recipient is changed to the last name shown in the drop down address book list!     It now requires an extra keystroke to confirm the recipient you want - you have to find the recipient and then click on that name.

The change made now forces an extra keystroke which makes the program less efficient, and there is the greater risk of the user not noticing that the program has changed the selected recipient and the email going to the wrong person.


Expected results:

The highlighted name at the top of the address book list should be the recipient, unless the user expressly clicks on another name from the drop down list from the address book.
Component: Untriaged → Message Compose Window
"Cursor moved" - how? Did you mean with the mouse or keyboard? What extra keystroke are you talking about?
Keywords: regression
Summary: Has change been made to addressing an email? → last entry selected from addressing autocomplete list when moving to subject
Hi Magnus

I think my report describes it clearly.  To address an email I enter the first few letters of their name until their name shows highlighted at the top of a drop down list from the address book.  

It used to be that I would then move the cursor - using the mouse - down to the body of the message, and the highlighted name would remain.  Now however when I use the mouse to move the cursor to move the cursor straight down the page to the message box, it changes the recipient to the last name in the drop down list.

In order to keep the intended recipient found by entering the first few letters of their name, you now have to make an extra keystroke by either hitting "Enter" when their name is highlighted, or you have to click on their name with the name.  This is the extra key stroke - it was not needed before.

The problem is to do with a change in the action of the drop down list box.  That now changes the selection of the recipient as the cursor is drawn down to the message box.  If the cursor is drawn away to the side around the drop down box, then the recipient does not change.   It never used to be this way - before when you found your recipient and moved the cursor to the message box, the recipient was not changed.

This has the potential for misaddressed emails - I've had a couple already - and it really slows things down always having to watch in case the recipient has been changed.  

Hope this is clear now.

Jason
Ah yes, I think there's a bug open for that already.
Whiteboard: DUPEME
Duplicate of this bug: 1152517
This bug was confirmed, so NEW until we find the dupe if there's yet another one.

TB swapping intended address to random addresses is very bad behaviour which violates privacy; it's also dataloss of the deliberately chosen recipient. -> critical.
Severity: normal → critical
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: dataloss, privacy
Summary: last entry selected from addressing autocomplete list when moving to subject → Recipient autocomplete randomly considers last mouse-hovered contact from results dropdown "selected" and then uses that upon blur (unintended, wrong recipient!!!)
Summary: Recipient autocomplete randomly considers last mouse-hovered contact from results dropdown "selected" and then uses that upon blur (unintended, wrong recipient!!!) → Recipient autocomplete considers last mouse-hovered contact from results dropdown "selected" and then uses that upon blur (e.g. when moving to subject)
(In reply to Magnus Melin from comment #3)
> Ah yes, I think there's a bug open for that already.

Bug 1140942.

I'll forward-duplicate Bug 1140942 and this bug 1144233 to Bug 1152517 which has much better STR, Screenshot, and explanation of the problem.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1152517
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.