News doesn't get notified of failure to reach server

VERIFIED DUPLICATE of bug 114328

Status

MailNews Core
Networking: NNTP
VERIFIED DUPLICATE of bug 114328
16 years ago
9 years ago

People

(Reporter: Bienvenu, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
If the news server is down or unreachable, nntp protocol doesn't get notified of
the error, and thus never tells the user. ::OnStopRequest gets an NS_OK status.
4.x puts up an error message when trying to connect to the same server.
(Reporter)

Comment 1

16 years ago
Seth thinks there might have been a recent check in necko that might be
responsible. My release build from a few days ago has this problem, so it has
been around for at least 4 days.
Summary: News doesn't get notified of failure to each server → News doesn't get notified of failure to reach server

Comment 2

16 years ago
you might try backing out my most recent checkin to nsSocketTransport.cpp

*** This bug has been marked as a duplicate of 114328 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
verified duplicate
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.