apz crash when a tab is moved to a new window

RESOLVED FIXED in Firefox 39

Status

()

Core
Panning and Zooming
--
critical
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Grant, Assigned: kats)

Tracking

({crash, crashreportid})

Trunk
mozilla39
x86
Windows NT
crash, crashreportid
Points:
---

Firefox Tracking Flags

(firefox39 fixed)

Details

(crash signature, URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
So,

1. Enable APZ in latest nightly
2. Browse to this URL and let flash load the game
3. Drag the tab to make a new window, the browser will crash with below crash report:

https://crash-stats.mozilla.com/report/index/7b54a41c-68f8-4b27-8d5e-1e53e2150317

I can reproduce this easily.

Comment 1

3 years ago
(In reply to Grant from comment #0)

> 2. Browse to this URL and let flash load the game


Which URL?
Flags: needinfo?(tenisthenewnine)
(Reporter)

Comment 2

3 years ago
Sorry, this one for example:

http://www.flashgames247.com/play/16892.html
Flags: needinfo?(tenisthenewnine)
Blocks: 1013364
Crash Signature: [@ nsRefPtr<mozilla::layers::HitTestingTreeNode>::assign_with_AddRef(mozilla::layers::HitTestingTreeNode*) | mozilla::layers::APZCTreeManager::PrepareNodeForLayer(mozilla::layers::LayerMetricsWrapper const&, mozilla::layers::FrameMetrics const&, un&hellip;
Component: Untriaged → Panning and Zooming
Keywords: crash, crashreportid
Product: Firefox → Core
(Reporter)

Comment 3

3 years ago
Might I add I can reproduce this both on Windows 10 TP and Windows 7. It says I'm using NT but that's just Windows 10
I can reproduce this. I don't think Flash is necessary here; I can repro on the same page by attempting to drag the tab into a new window even though I don't have flash. I can investigate.
Assignee: nobody → bugmail.mozilla
Status: UNCONFIRMED → NEW
Ever confirmed: true
Created attachment 8580036 [details] [diff] [review]
Patch

Looks like a layer is getting transplanted from one LayerManager to another, and the APZ code doesn't handle that properly. Fix attached.
Attachment #8580036 - Flags: review?(botond)
Summary: apz plugin crash when open new window → apz crash when a tab is moved to a new window

Updated

3 years ago
Attachment #8580036 - Flags: review?(botond) → review+

Updated

3 years ago
Severity: normal → critical
https://hg.mozilla.org/mozilla-central/rev/2463904da0cc
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox39: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla39
You need to log in before you can comment on or make changes to this bug.