[gonk-lmr1] Adapt configure.in and b2g/app/moz.build to platform SDK version 22

RESOLVED FIXED in Firefox 40, Firefox OS v2.2

Status

Firefox OS
GonkIntegration
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: m1, Assigned: m1)

Tracking

(Blocks: 1 bug)

unspecified
2.2 S9 (3apr)
x86
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, firefox38 wontfix, firefox39 wontfix, firefox40 fixed, b2g-v2.2 fixed, b2g-master fixed)

Details

(Whiteboard: [caf priority: p2][CR 810043])

Attachments

(1 attachment)

L MR1 is version 22 [1], configure.in and b2g/app/moz.build need to be updated.

[1] http://androidxref.com/5.1.0_r1/xref/build/core/version_defaults.mk#56

Comment 1

3 years ago
Hi Michael Wu,

Can you help route this to the right owner.

Thanks,
Mike
Flags: needinfo?(mwu)

Comment 2

3 years ago
+ Shawn Ku for help finding an owner for this.
Flags: needinfo?(sku)

Updated

3 years ago
Whiteboard: [CR 810043]

Updated

3 years ago
Whiteboard: [CR 810043] → [caf priority: p2][CR 810043]
(Assignee)

Comment 3

3 years ago
Created attachment 8581062 [details] [diff] [review]
0001-Bug-1144512-Add-b2g-build-support-for-API-level-22.patch

Not sure who needs to review this for it to land (and I'm PTO for the next two weeks)
(Assignee)

Comment 4

3 years ago
(goto v2.2+, as we do really need this)
blocking-b2g: --- → 2.2+

Comment 5

3 years ago
Comment on attachment 8581062 [details] [diff] [review]
0001-Bug-1144512-Add-b2g-build-support-for-API-level-22.patch

Review of attachment 8581062 [details] [diff] [review]:
-----------------------------------------------------------------

Hi gps
 Can you help review this patch?
Attachment #8581062 - Flags: review?(gps)

Updated

3 years ago
Flags: needinfo?(sku)

Updated

3 years ago
Attachment #8581062 - Flags: review?(gps) → review+

Updated

3 years ago
Flags: needinfo?(mwu)

Updated

3 years ago
Assignee: nobody → mvines

Comment 6

3 years ago
mwu -- since m1 is on PTO, can you please find someone to take it forward and get this landed?
Flags: needinfo?(mwu)

Comment 7

3 years ago
Yup we're working on it - Kai-Zhen is currently working on updating our nexus-5 L port to lmr1, and he'll be doing a basic test of these patches before they land.
Flags: needinfo?(mwu)
I applied this patch locally and it does work properly.
try result: https://treeherder.mozilla.org/#/jobs?repo=try&revision=34857d936909
https://hg.mozilla.org/integration/b2g-inbound/rev/256daeb9f1af
Blocks: 1147266
https://hg.mozilla.org/mozilla-central/rev/256daeb9f1af
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox40: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S9 (3apr)
Comment on attachment 8581062 [details] [diff] [review]
0001-Bug-1144512-Add-b2g-build-support-for-API-level-22.patch

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Gonkintegration
User impact if declined: b2g build on L will not work in v2.2
Testing completed: master
Risk to taking this patch (and alternatives if risky): low, update api level accordingly
String or UUID changes made by this patch: none
Attachment #8581062 - Flags: approval-mozilla-b2g37?

Updated

3 years ago
Attachment #8581062 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/940cd5079a33
status-b2g-v2.2: --- → fixed
status-b2g-master: --- → fixed
status-firefox38: --- → wontfix
status-firefox39: --- → wontfix
You need to log in before you can comment on or make changes to this bug.