If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Disconnected call: calls another random contact

RESOLVED WORKSFORME

Status

Firefox OS
General
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: David Ross, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0 Iceweasel/31.5.0
Build ID: 20150225035911

Steps to reproduce:

Nightly build 20150316160204. Was on a call to a contact and the connection dropped. Call waiting is set to off. Walking through central London.


Actual results:

Phone had TWO calls showing on display. Voicemail was called somehow. I tried closing that call to get back to contact. Voicemail call closes, original call not connected despite display saying it is.

So he calls back. And after a few moments the call drops again. This time the phone has called one of the first entries from 'A' in my contacts. After a few minutes of explaining why it's been so long since I last rang (so embrassing!!) I hang up and again the original call is supposedly connected but is not.


Expected results:

I should have just stayed connected with the original call without randomly calling voicemail or the old friend.
(Reporter)

Comment 1

3 years ago
Possibly related: on an important account call and swapped hands to have call hang up on me. I am presuming there is some 'in call' keypad action taking place?
(Reporter)

Comment 2

3 years ago
This is driving me crazy. 

It seems the keypad is silently activating during a call and I am dialling another contact. Despite call waiting disabled in my settings. 

Most of the time I lose the original call in the process. Dialling with my ear during a call means random contacts all over the globe are being phoned. Like a prize draw but with no winners.
(Reporter)

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.