Closed Bug 1144567 Opened 5 years ago Closed 5 years ago

[Marketplace]The Marketplace will exit directly when you launch it.

Categories

(Firefox OS Graveyard :: RIL, defect, blocker)

ARM
Gonk (Firefox OS)
defect
Not set
blocker

Tracking

(blocking-b2g:2.5+, b2g-master verified)

VERIFIED FIXED
blocking-b2g 2.5+
Tracking Status
b2g-master --- verified

People

(Reporter: lulu.tian, Unassigned)

References

Details

(Keywords: regression, smoketest, Whiteboard: [fromAutomation])

Attachments

(2 files)

193.49 KB, text/plain
Details
1.48 MB, video/mp4
Details
Attached file logcat_1849.txt
[1.Description]:
[Flame v3.0][Nexus 5 v3.0][Marketplace]When you launch Marketplace app, it can't be opened and will exit directly.
Found time:18:49
See attachment:1849.MP4 and logcat_1849.txt

[2.Testing Steps]: 
1. Launch Marketplace.

[3.Expected Result]: 
1. Marketplace should be opend normally.

[4.Actual Result]: 
1. It will exit directly.

[5.Reproduction build]: 
Flame 2.2 build: unaffected
Build ID               20150317162504
Gaia Revision          306772a58335ac4cad285d27c3805090a8cc6886
Gaia Date              2015-03-17 17:12:36
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/83251e534b33
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150317.195036
Firmware Date          Tue Mar 17 19:50:45 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 build: affected
Build ID               20150317160205
Gaia Revision          63d6639acd771f548a2613f07f3e335921e4ac87
Gaia Date              2015-03-17 16:53:50
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e965a1a534ec
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150317.195927
Firmware Date          Tue Mar 17 19:59:39 EDT 2015
Bootloader             L1TC000118D0

Nexus 5 3.0 build: affected
Build ID               20150317160205
Gaia Revision          63d6639acd771f548a2613f07f3e335921e4ac87
Gaia Date              2015-03-17 16:53:50
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e965a1a534ec
Gecko Version          39.0a1
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150317.194723
Firmware Date          Tue Mar 17 19:47:37 EDT 2015
Bootloader             HHZ12d

Nexus 5 2.2 build: unaffected
Build ID               20150317162504
Gaia Revision          306772a58335ac4cad285d27c3805090a8cc6886
Gaia Date              2015-03-17 17:12:36
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/83251e534b33
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150317.195033
Firmware Date          Tue Mar 17 19:50:47 EDT 2015
Bootloader             HHZ12d

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
Attached video 1849.MP4
Flags: needinfo?(whsu)
[Blocking Requested - why for this release]:

A regression bug.
Also, it blocks our daily smoke test.
Severity: major → blocker
blocking-b2g: --- → 3.0?
Flags: needinfo?(whsu)
b2g-inbound-tinderbox regression window found from the Jenkins automated tests.
-------------------------------------------------------------------

Last passing:
Device firmware (base) 	L1TC100118D0
Device firmware (date) 	17 Mar 2015 05:11:16
Device firmware (incremental) 	eng.cltbld.20150317.081104
Device firmware (release) 	4.4.2
Device identifier 	flame
Gaia date 	17 Mar 2015 03:19:20
Gaia revision 	fbe14c2b73db
Gecko build 	20150317040834
Gecko revision 	d97c943e3cbc
Gecko version 	39.0a1


First failing:
Device firmware (base) 	L1TC100118D0
Device firmware (date) 	17 Mar 2015 05:11:16
Device firmware (incremental) 	eng.cltbld.20150317.081104
Device firmware (release) 	4.4.2
Device identifier 	flame
Gaia date 	17 Mar 2015 05:40:50
Gaia revision 	742e119da2ac
Gecko build 	20150317062432
Gecko revision 	43528afb1ca5
Gecko version 	39.0a1
QA Whiteboard: [QAnalyst-Triage?]
Accidentally cut the keywords on my last comment. Reinstating them.
QA Contact: bzumwalt
03-18 18:49:45.098 I/Gecko   (  206): ###!!! [Parent][DispatchAsyncMessage] Error: (msgtype=0x360058,name=PContent::Msg_PIccConstructor) Value error: message was deserialized, but contained an illegal value
03-18 18:49:45.098 I/Gecko   (  206): [Parent 206] WARNING: waitpid failed pid:1772 errno:10: file ../../../gecko/ipc/chromium/src/base/process_util_posix.cc, line 267
03-18 18:49:45.108 I/Gecko   (  206): ###!!! [Parent][MessageChannel] Error: Channel error: cannot send/recv
03-18 18:49:45.118 I/GeckoDump(  206): [system] [AppWindow][Marketplace][AppWindow_8][35006.967]  Handling mozbrowsererror event...
03-18 18:49:45.118 I/GeckoDump(  206): [system] [AppWindow][Marketplace][AppWindow_8][35006.968] publishing internal event: crashed
03-18 18:49:45.118 I/GeckoDump(  206): [system] [AppWindow][Marketplace][AppWindow_8][35006.969] publishing external event: crashed
03-18 18:49:45.128 I/GeckoDump(  206): [system] [AppWindow][Marketplace][AppWindow_8][35006.971] publishing internal event: requestclose
03-18 18:49:45.128 I/GeckoDump(  206): [system] [AppWindow][Marketplace][AppWindow_8][35006.971] publishing external event: requestclose

Ya.  The app crashed for sure.
Confirming that window in comment 3 and pushlog in comment 5 are correct. Removing keywords.
Flags: needinfo?(ktucker)
Privacy, lockscreen, notification in the window for gaia.  Looks like a gecko regression for sure.

Bug 1134448 - merge pull request #28906 from zbraniecki:1134448-priva… …
autolander authored a day ago
@gmarty

Bug 1140321 - [RTL][Download] Fail to download the file, then the err… …
gmarty authored 7 days ago
@autolander

Bug 1142436 - merge pull request #28879 from snowmantw:bug1142436 to … …
autolander authored a day ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Bevis, can you take a look at this please? Looks like the work done on bug 1114935 might have caused this so we might need to back this out.
Blocks: 1114935
Flags: needinfo?(btseng)
Resolving fixed with the backout of bug 1114935
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1144864
Flags: needinfo?(btseng)
Verified fixed on the latest Flame 3.0.
Marketplace app launches properly.

Environmental Variables:
Device: Flame 3.0
Build ID: 20150319010201
Gaia: c39e15f631de80c69467fda0d4ea0bcda9e194ca
Gecko: cf1060d8ce9f
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Duplicate of this bug: 1146053
Moving the bug to the component where the regression came from.
blocking-b2g: 2.5? → 2.5+
Component: Gaia::System → RIL
Based on the report sent on March 18th, this issue was caught by automation.
Whiteboard: [fromAutomation]
You need to log in before you can comment on or make changes to this bug.