[RTL][Contacts]The "+" symbol is shown at wrong side of phone number in "Duplicates found" view.

VERIFIED FIXED in 2.2 S9 (3apr)

Status

defect
P2
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: yulan.zhu, Assigned: arcturus)

Tracking

unspecified
2.2 S9 (3apr)
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(4 attachments)

[1.Description]:
[Flame][v2.2&v3.0][Contacts]New two contacts with the same phone number, the "+" symbol is shown at wrong side of phone number in "Duplicates found" view.
See attachment:Screenshot_phone number.png

[2.Testing Steps]: 
1.Launch Contact.
2.New a contact and the phone number with "+" symbol.
3.New another contact with the same phone number.
**The "Duplicates found" view pops up.
4.Observe the view.

[3.Expected Result]: 
4.The "+" symbol should be displayed at left side of the phone number.

[4.Actual Result]: 
4.The "+" symbol is shown at wrong side of phone number

[5.Reproduction build]: 
Flame 2.2 build (Affected):
Build ID               20150317162504
Gaia Revision          306772a58335ac4cad285d27c3805090a8cc6886
Gaia Date              2015-03-17 17:12:36
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/83251e534b33
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150317.195036
Firmware Date          Tue Mar 17 19:50:45 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 build (Affected):
Build ID               20150317073344
Gaia Revision          738987bd80b0ddb4ccf853855388c2627e19dcc1
Gaia Date              2015-03-17 02:27:51
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/008b3f65a7e0
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150317.111450
Firmware Date          Tue Mar 17 11:15:00 EDT 2015
Bootloader             L1TC000118D0


[6.Reproduction Frequency]: 
Always Recurrence,10/10

[7.TCID]: 
Free Test
QA Whiteboard: [rtl-impact]
Triage: P2. Nominating as this is not giving the user the correct information and is not in line with RTL specs throughout the UI. Can cause much confusion
blocking-b2g: --- → 2.2?
Priority: -- → P2
Comms triage: Inconsistency on a panel which could be easily displayed to an end user. Blocking.
blocking-b2g: 2.2? → 2.2+
Assignee: nobody → francisco
Status: NEW → ASSIGNED
Comment on attachment 8580778 [details] [review]
[gaia] arcturus:bug-1144592 > mozilla-b2g:master

Fernando can you take a look?
Attachment #8580778 - Flags: review?(ferjmoreno)
Attachment #8580778 - Flags: review?(ferjmoreno) → review+
Comment on attachment 8580778 [details] [review]
[gaia] arcturus:bug-1144592 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
RTL
[User impact] if declined:
Bad user experience
[Testing completed]:
[Risk to taking this patch] (and alternatives if risky):
[String changes made]:
Attachment #8580778 - Flags: approval-gaia-v2.2?
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Attachment #8580778 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This issue is not fixed in the latest Nightly Flame 3.0 and 2.2 builds.

Actual Results:  The phone number has the + on the right if the contact does not have a name (see attached screenshot)

Environmental Variables:
Device: Flame 3.0
BuildID: 20150325083046
Gaia: aebfbd998041e960cea0468533c0b5041b504850
Gecko: db0409de517a
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Environmental Variables:
Device: Flame 2.2
BuildID: 20150325002503
Gaia: aeee2a54caa8ffb875b96264b61d742b70689f22
Gecko: 556aca3e50ac
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [rtl-impact] → [QAnalyst-Triage?][rtl-impact][failed-verification]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][rtl-impact][failed-verification] → [QAnalyst-Triage+][rtl-impact][failed-verification]
Flags: needinfo?(ktucker)
Posted image dup_contacts.png
When you add a duplicate contacts with a name in step 3, the "Duplicates found" view will pop up and show correctly. But if you add a duplicate contacts only with phone number, the "Duplicates found" view will pop up and the "+" will show at right side of the phone number.
See attachment:dup_contacts.png
Device: Flame 2.2/3.0
QA Whiteboard: [QAnalyst-Triage+][rtl-impact][failed-verification] → [QAnalyst-Triage+][rtl-impact][failed-verification][MGSEI-Triage+]
Hi Francisco,
Per comment 11, Could you help with it? Thanks!
Flags: needinfo?(francisco)
Thanks for spotting this new issue, Sue. Can you open a new bug for it and make it block "contacts-rtl" and 1144592?
Flags: needinfo?(francisco) → needinfo?(lulu.tian)
Depends on: 1148259
See Also: → 1148259
(In reply to Johan Lorenzo [:jlorenzo] (QA) from comment #13)
> Thanks for spotting this new issue, Sue. Can you open a new bug for it and
> make it block "contacts-rtl" and 1144592?

I have opened a new bug, see Bug 1148259.
No longer depends on: 1148259
Flags: needinfo?(lulu.tian)
Depends on: 1148259
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15443/
Flags: in-moztrap+
Per comment 11~14, this issue had been verified passed. Change the status to VERIFIED, FIXED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.