Closed Bug 1144593 Opened 5 years ago Closed 5 years ago

[Statusbar] Icons color is wrong when coming back from search

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

x86
macOS
defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.1S unaffected, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S9 (3apr)
blocking-b2g 2.2+
Tracking Status
b2g-v2.1 --- unaffected
b2g-v2.1S --- unaffected
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: apastor, Assigned: apastor)

References

Details

(Whiteboard: [systemsfe])

Attachments

(5 files, 1 obsolete file)

STR:

1.- Open the browser
2.- Click on the search bar
3.- Unfocus the keyboard (for example, longpressing the power button, and clicking 'Cancel')
4.- Close the searc

Expected:

The statusbar icons are visible

Actual

The statusbar icons are white over white
Not sure if is a regression. Could qa check branches? Thanks!
Keywords: qawanted
I'm finding the broken window.
This problem can be repro on latest build of Flame 2.2 and 3.0, but it cannot be repro on Flame2.1/2.1s(512mb). (On Flame 2.0 Browser view, it doesn't support search bar.)
See attachmen: Flame3.0_logcat_0407.txt & Flame3.0_video.MP4
Flame2.2/3.0 fail rate:5/5

Flame 2.1 build: (Pass)
Build ID               20150318001207
Gaia Revision          13c85d57f49b4bfd657ff674f2b530c141c94803
Gaia Date              2015-03-17 13:31:54
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/2fbd284621e2
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150318.040035
Firmware Date          Wed Mar 18 04:00:46 EDT 2015
Bootloader             L1TC000118D0

2.1s_512mb build: (Pass)
Build ID               20150318161205
Gaia Revision          13c85d57f49b4bfd657ff674f2b530c141c94803
Gaia Date              2015-03-17 13:31:54
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1s/rev/e64b1776894a
Gecko Version          34.0
Device Name            scx15_sp7715ea
Firmware(Release)      4.4.2
Firmware(Incremental)  122
Firmware Date          Thu Feb  5 12:42:58 CST 2015

Flame 2.2 build: (Fail)
Build ID               20150318002504
Gaia Revision          306772a58335ac4cad285d27c3805090a8cc6886
Gaia Date              2015-03-17 17:12:36
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/a6f5f4035ea5
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150318.040534
Firmware Date          Wed Mar 18 04:05:45 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 build: (Fail)
Build ID               20150318055750
Gaia Revision          b8051d370ddf4e5bd8e7d8a19fb9eeb5fd6ffb39
Gaia Date              2015-03-18 07:48:50
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/41a61514461e
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150318.093634
Firmware Date          Wed Mar 18 09:36:44 EDT 2015
Bootloader             L1TC000118D0

b2g-inbound regression window:
Device: Flame
Last Working Environmental Variables:
Gaia-Rev        b3fe0b0741252e18fdceded00595bd559e6c2bf1
Gecko-Rev       https://hg.mozilla.org/integration/b2g-inbound/rev/337a83bd43ea
Build-ID        20150227061344
Version         39.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150318.035405
FW-Date         Wed Mar 18 03:54:15 EDT 2015
Bootloader      L1TC000118D0

First Broken Environmental Variables:
Device: Flame
Gaia-Rev        640712b2b5773ece064a4958cf812a3ff348ed06
Gecko-Rev       https://hg.mozilla.org/integration/b2g-inbound/rev/79e9b035ae8d
Build-ID        20150227062844
Version         39.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150318.035405
FW-Date         Wed Mar 18 03:54:15 EDT 2015
Bootloader      L1TC000118D0

First Broken Gaia & Last Working Gecko - issue DOES repro
Gaia: 640712b2b5773ece064a4958cf812a3ff348ed06
Gecko: 337a83bd43ea

First Broken Gecko & Last Working Gaia - issue does NOT repro
Gaia: b3fe0b0741252e18fdceded00595bd559e6c2bf1
Gecko: 79e9b035ae8d
blocking-b2g: --- → 2.2?
Assignee: nobody → apastor
Guillaume, it seems that [1] created this regression. Do you want to take it? Thanks!

[1] https://github.com/mozilla-b2g/gaia/commit/640712b2b5773ece064a4958cf812a3ff348ed06
Flags: needinfo?(gmarty)
Blocks: 1128618
Blocking a blocker
blocking-b2g: 2.2? → 2.2+
Attachment #8580658 - Attachment is obsolete: true
Thanks Alberto for taking it. I was talking at a conference on Thursday and busy catching up on Friday.
Let me know when your patch is ready for review.
Flags: needinfo?(gmarty)
Attachment #8580718 - Flags: review?(gmarty)
Comment on attachment 8580718 [details] [review]
[gaia] albertopq:1144593-icons-color-search2 > mozilla-b2g:master

Looks good to me. I just left a question on Github.
Attachment #8580718 - Flags: review?(gmarty) → review+
master: https://github.com/mozilla-b2g/gaia/commit/79028b246427e60eb717b9123538f279644c0757
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8580718 [details] [review]
[gaia] albertopq:1144593-icons-color-search2 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: Wrong statusbar colors when coming back from the search view
[Testing completed]: Added unit tests
[Risk to taking this patch] (and alternatives if risky): Reasonably simple patch. Just listening to a new event, and added unit tests.
[String changes made]:
Attachment #8580718 - Flags: approval-gaia-v2.2?(bbajaj)
Comment on attachment 8580718 [details] [review]
[gaia] albertopq:1144593-icons-color-search2 > mozilla-b2g:master

[Triage Comment]
Attachment #8580718 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
Attached video Flame3.0_verify.MP4
This problem is verified pass on latest build of Flame 3.0.
See attachment: Flame3.0_verify.MP4
Rate:0/10
Device: Flame 3.0 (Pass)
Build ID               20150327160203
Gaia Revision          9cc496cecc37d7a29f9279827cdf6e4891211f67
Gaia Date              2015-03-27 13:55:18
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/44e454b5e93b
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150327.192632
Firmware Date          Fri Mar 27 19:26:42 EDT 2015
Bootloader             L1TC000118D0

Leaving verifyme keyword for 2.2 uplift.
Shine, please help verify 2.2.
Flags: needinfo?(yue.xia)
This problem is verified pass on latest build of Flame 2.2 by the STR in comment 0.
See attachment: Flame2.2_verify_video.mp4
Rate: 0/5
Device: Flame 2.2(Pass)
Build ID               20150414162502
Gaia Revision          16e948bfaaa15dbc0200135d52f16257b4eab193
Gaia Date              2015-04-14 21:08:25
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/0eec28e78eb1
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150414.201515
Firmware Date          Tue Apr 14 20:15:24 EDT 2015
Bootloader             L1TC000118D0
Flags: needinfo?(yue.xia)
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.