Unable to share contact info via bluetooth from contact detail panel

VERIFIED FIXED in 2.2 S9 (3apr)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: brg, Assigned: hola)

Tracking

unspecified
2.2 S9 (3apr)
x86
macOS
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(4 attachments)

Reporter

Description

4 years ago
Testing in master and 2.2, it is not possible to share contact info from contact detail panel while it is working very welll from Export option inside Contacts app.

STR:
- Contacts -> Open a Contact info panel -> Share Contact --> Bluetooth
- Pair with another device Flame or android (not possible to test with iphone due to bug 1144604).
- Flames try to share the vcard and starts BT transfer and then two scenarios had been detected:
A.- Nothing is received in the other device. See attachment: BT transfer starts but nothing else happens
B.- A corrupted file is shared with the other side which cannot be opened. Find attach the three screenshots of the process with a lot of unknown labels.

Please keep in mind that using the same devices the option to Export contacts via BT is working very well without the unknow labels and being able to receive the contact info.

Environmental variables:
Today's (3/18) v2.2 build:
Flame device
Gecko: 3e33c08
Gaia: 306772a
Build Id: 20150318081247
Platform version: 37.0

Today's (3/18) master build:
Flame device
Gecko: cebcc63
Gaia: 70bac3a
Build Id: 20150318082350
Plarform version: 39.0a1
Reporter

Comment 2

4 years ago
This is a broken feature tested during certification process.
blocking-b2g: --- → 2.2?
See Also: → 1140247
Comms triage: Broken new functionality.
blocking-b2g: 2.2? → 2.2+
Adrian, please, can you have a look at it? 
Tracing I've seen this error, that seems to be related to some issue between Contact and BT activities:

W/Bluetooth Manager(10586): [JavaScript Error: "TypeError: activity.source.data.filepaths is undefined" {file: "app://bluetooth.gaiamobile.org/js/transfer.js" line: 206}]

Thanks a lot!
Flags: needinfo?(hola)
Assignee

Comment 5

4 years ago
Taking it, I'll give it a look!
Assignee: nobody → hola
Flags: needinfo?(hola)
bug 1140247 should fix this problem. Can you verify the latest version again?
Flags: needinfo?(beatriz.rodriguezgomez)
(In reply to Shawn Huang [:shawnjohnjr] from comment #6)
> bug 1140247 should fix this problem. Can you verify the latest version again?

We reported this issue after landing bug 1140247 in master branch and as you can see in comments 32, 33 and 36 of that bug 1140247, it explains:
"There is a new problem here,The contact is shared and can be received by the other device.  However the received file is considered unknown and cannot be opened" , 

That's the fault reported by Beatriz in this bug (scenario B) and it continues happening and is different from the one reported in bug 1140247.
Reporter

Comment 8

4 years ago
Already clarified by comment 7. Thanks Maria!
Flags: needinfo?(beatriz.rodriguezgomez)
Assignee

Comment 10

4 years ago
Comment on attachment 8583104 [details] [review]
[gaia] ADLR-es:1144610 > mozilla-b2g:master

Simpler fix than I thought. The bluetooth activity was expecting a File object just because it requires a filename to be able to send the file. I just created a File object from the vCard blob and everything works as expected.
Attachment #8583104 - Flags: review?(jmcf)
Comment on attachment 8583104 [details] [review]
[gaia] ADLR-es:1144610 > mozilla-b2g:master

Stealing the review, tried on the phone and working for me.
Attachment #8583104 - Flags: review?(jmcf) → review+
Target Milestone: --- → 2.2 S9 (3apr)
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Adrian, could you ask for uplift?
Flags: needinfo?(hola)
Comment on attachment 8583104 [details] [review]
[gaia] ADLR-es:1144610 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined:
[Testing completed]:
Tested on device
[Risk to taking this patch] (and alternatives if risky):
Low
[String changes made]:
Flags: needinfo?(hola)
Attachment #8583104 - Flags: approval-gaia-v2.2?
Attachment #8583104 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Reporter

Comment 16

4 years ago
Tested with todays builds in Flame master and v2.2, it is working well, I can share contact info from Contact details panel and I have not seen any "unknown" label during the process. Thanks for fixing it.

Master build details: Gecko-3e6e4cf.Gaia-4bb3a93
v2.2 build: Gecko-2b3fa8b.Gaia-8b3086a
According to the STR of Comment 0, this bug has been successfully verified on latest Nightly Flame v2.2&3.0. 

Actual results:Can share contact info via bluetooth from contact detail panel,and other devices(Flame or Android) can receive/open VCF file normally.

See attachment: verified_v2.2&3.0.MP4
Reproduce rate: 0/5

----------------------------------------------------------------------------
Device: Flame 2.2 build(Pass)
Build ID               20150409002503
Gaia Revision          ea735c21bfb0d78333213ff0376fce1eac89ead6
Gaia Date              2015-04-07 20:58:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/0efd5cdbe224
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150409.041814
Firmware Date          Thu Apr  9 04:18:23 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 build(Pass)
Build ID               20150409160204
Gaia Revision          eaf69e651e19b98c096f8e63b9829fb31df50927
Gaia Date              2015-04-09 12:43:21
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/dd32e3ff3717
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150409.193255
Firmware Date          Thu Apr  9 19:33:06 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
QA Whiteboard: [MGSEI-Triage+]
Depends on: 1186108
You need to log in before you can comment on or make changes to this bug.