Missing string in Camera permission prompt for privileged and trusted hosted applications

RESOLVED DUPLICATE of bug 1144784

Status

Firefox OS
Gaia::System
RESOLVED DUPLICATE of bug 1144784
3 years ago
3 years ago

People

(Reporter: oteo, Assigned: fcampo)

Tracking

({late-l10n})

unspecified
ARM
Gonk (Firefox OS)
late-l10n

Firefox Tracking Flags

(b2g-v2.2 affected)

Details

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8579326 [details]
2015-03-10-16-10-24.png

According to the Permissions table (http://mxr.mozilla.org/mozilla-central/source/dom/apps/PermissionsTable.jsm) for privileged and trusted hosted aplications that use Camera API a prompt should be shown to allow or not using this API.

Right now there is a string missing in the prompt (see attachment) about the permission that the users have to allow or not. This can be confusing and a string like "XXXXX app would like to access to your camera" is necessary.

W/GeckoConsole(15400): Content JS WARN: L10nError: "perm-camera-appRequest" not found in en-US in app://system.gaiamobile.org/index.html
W/GeckoConsole(15400):     at reportMissingEntity (app://system.gaiamobile.org/shared/js/l10n.js:1570:8)
(Assignee)

Updated

3 years ago
Assignee: nobody → fernando.campo
(Reporter)

Updated

3 years ago
Status: NEW → ASSIGNED
Created attachment 8581761 [details] [review]
[gaia] fcampo:camera-permission-1144642 > mozilla-b2g:master
(Assignee)

Comment 2

3 years ago
Comment on attachment 8581761 [details] [review]
[gaia] fcampo:camera-permission-1144642 > mozilla-b2g:master

small patch, only strings missing. 

Following same pattern as the rest of permissions
Attachment #8581761 - Flags: review?(alive)
(Assignee)

Comment 3

3 years ago
Created attachment 8581770 [details]
after_screenshot
Attachment #8581770 - Flags: ui-review?(swilkes)
Comment on attachment 8581761 [details] [review]
[gaia] fcampo:camera-permission-1144642 > mozilla-b2g:master

If this needs to uplift to v2.2 you will need l10n guys feedback. r+ for master
Attachment #8581761 - Flags: review?(alive) → review+
(Reporter)

Comment 5

3 years ago
It would be great if it could be uplifted to 2.2 (if it's set as 2.2+), but I am not sure if it's too late for localization team... Axel, are we still on time? In case we are, I'll nominate it.
Flags: needinfo?(l10n)
String freeze is on April 6, and approval needs to come from release drivers, not l10n ;-)
Flags: needinfo?(l10n)
Keywords: late-l10n
(Reporter)

Comment 7

3 years ago
Nominating to 2.2 as this is a small and very low risk that patch that in case a third party application uses the camera API, the missing string in the permission prompt results confusing for the end-users.
blocking-b2g: --- → 2.2?
status-b2g-v2.2: --- → affected
(Assignee)

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed
http://docs.taskcluster.net/tools/task-graph-inspector/#IjCGuDisS6isMZ-rZ4gY1A

The pull request failed to pass integration tests. It could not be landed, please try again.
(Reporter)

Comment 9

3 years ago
It seems that Borja already fixed this issue in bug 1144784, already landed in master.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1144784
(Reporter)

Updated

3 years ago
blocking-b2g: 2.2? → ---

Comment 10

3 years ago
Comment on attachment 8581770 [details]
after_screenshot

Removing the flag to me since this is resolved dupe.
Attachment #8581770 - Flags: ui-review?(swilkes)
You need to log in before you can comment on or make changes to this bug.