[Rocketbar] When closing an app with the search opened, it goes back to the search

VERIFIED FIXED in 2.2 S9 (3apr)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: apastor, Assigned: apastor)

Tracking

unspecified
2.2 S9 (3apr)
x86
macOS
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(2 attachments)

Assignee

Description

4 years ago
Not sure if this is a bug, but I wasn't expecting that as a user.

STR:

1.- Open any app with rocketbar (the browser, for example)
2.- Click on the search bar
3.- Longpress the home button, going to the cards view
4.- Close the app

Expected (what I expected, at least):

The search gets closed when longpressing the homebutton and, after closing the app, it goes to the homescreeen

Actual:

After closing the app, it goes back to the search results screen
Assignee

Comment 1

4 years ago
Francis, could you please confirm if that's the expected behavior? Note that, when switching apps (or going back to the same app) in the cards view during a search, the search does get closed.
Flags: needinfo?(fdjabri)
Assignee

Updated

4 years ago
Keywords: uiwanted
Hi Alberto, 

I agree with your bug. I thought I had this covered in the spec but I'll this case in. If the user invokes the task manager, then the search app should close but maintain its state. 

Thanks, Francis
Flags: needinfo?(fdjabri)
Assignee

Updated

4 years ago
Assignee: nobody → apastor
blocking-b2g: --- → 2.2?
Assignee

Comment 4

4 years ago
Comment on attachment 8583689 [details] [review]
[gaia] albertopq:1144655-rocketbar-app > mozilla-b2g:master

Francis, could you please check if the attached patch implements the expected behavior? Thanks!
Attachment #8583689 - Flags: ui-review?(fdjabri)
not a blocker to release due to edge case
blocking-b2g: 2.2? → ---
Target Milestone: --- → 2.2 S9 (3apr)
Looks good to me Alberto, thanks!
Assignee

Updated

4 years ago
Attachment #8583689 - Flags: ui-review?(fdjabri) → review?(kgrandon)
Comment on attachment 8583689 [details] [review]
[gaia] albertopq:1144655-rocketbar-app > mozilla-b2g:master

lgtm, thanks!
Attachment #8583689 - Flags: review?(kgrandon) → review+
https://github.com/mozilla-b2g/gaia/pull/29169

The pull request could not be applied to the integration branch. Please try again after current integration is complete. You may need to rebase your branch against the target branch.
(In reply to Autolander from comment #8)
> https://github.com/mozilla-b2g/gaia/pull/29169
> 
> The pull request could not be applied to the integration branch. Please try
> again after current integration is complete. You may need to rebase your
> branch against the target branch.

Doh, this is due to the current integration in bug 1150143. Should be a fairly straightforward rebase after that one lands. (Would prefer to wait for that integration to finish).
Assignee

Updated

4 years ago
Keywords: uiwantedcheckin-needed
Assignee

Updated

4 years ago
Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
This resolved bug 1159662 on Master. Can we get this uplifted to 2.2?
Gregor,

Could you please help determine if we need to uplift the patch to fix bug 1159662 for 2.2?
Flags: needinfo?(anygregor)
Assignee

Comment 13

4 years ago
Comment on attachment 8583689 [details] [review]
[gaia] albertopq:1144655-rocketbar-app > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): -
[User impact] if declined: Keeping the search open while in the cards view, can create weird states like this bug is describing or related to the thumbnails (see 1159662)
[Testing completed]: Unit tests. In master for months.
[Risk to taking this patch] (and alternatives if risky): Given the low complexity of the fix, the tests added, and that has been in master for months without problems, I would say is low risk
[String changes made]: none
Attachment #8583689 - Flags: approval-gaia-v2.2?(bbajaj)
Fixes a blocker.
blocking-b2g: --- → 2.2+
Flags: needinfo?(anygregor)
Comment on attachment 8583689 [details] [review]
[gaia] albertopq:1144655-rocketbar-app > mozilla-b2g:master

Given this fixes a blocker , approving this change for 2.2
Attachment #8583689 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
Flags: needinfo?(hcheng)
Assignee

Updated

4 years ago
Duplicate of this bug: 1159662
This issue is verified fixed on Flame Master and 2.2.

Result: Search screen does not reappear, and the homescreen is displayed properly.

Environmental Variables:
Device: Flame 3.0 (KK, 319mb, full flash)
Build ID: 20150508010203
Gaia: bc5bfa18f795919b56b952bbf3637c235d0e13dc
Gecko: 356e735fa908
Gonk: a9f3f8fb8b0844724de32426b7bcc4e6dc4fa2ed
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0


Environmental Variables:
Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20150508002501
Gaia: 88d3ac2721a5484495c2ed60e4a068945f0de5aa
Gecko: 8ad16ebe659d
Gonk: ab265fb203390c70b8f2a054f38cf4b2f2dad70a
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Flags: needinfo?(hcheng)
You need to log in before you can comment on or make changes to this bug.