HTML mail doesn't send in html, sends plain text instead (due to delivery-format: auto-detect)

RESOLVED INVALID

Status

RESOLVED INVALID
17 years ago
3 years ago

People

(Reporter: wsheets, Assigned: sspitzer)

Tracking

(Blocks: 1 bug)

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.6+) Gecko/20011210
BuildID:    

If I compose an email message in html it clearly works up until
I actually hit the Send button.  If I Save the message before
Sending then the "Saved" copy is in html, but the "Sent" message
is in ascii with a few odd formatting characters.

(Personally, I don't care.  I think html mail should all hit the
bit bucket on the way out ;-)


Reproducible: Always
Steps to Reproduce:
1.Check the HTML checkbox in Mail/News preferences.
2.Compose a message.
3.Save it first, then Send it. Compare the two versions.


Actual Results:  "Sent" version is not html.

Expected Results:  "Sent" version should be html.

Dunno if this is new or old.  This is the first time
I've ever sent html email.
are you sending to a recipient who is marked as not getting HTML mail?
(Reporter)

Comment 2

17 years ago
Seems like a fair question--I was just sending it to myself as a test--
at my sbcglobal.com address.  How do I tell if I'm 'marked' or not?
Look in your address book for your e-mail address, likely it is in collected
e-mail addresses, but could be in other folders.

Do a properties on it and see what format you're listed as.  You can set it to
HTML mail if it's not already.  Please report back your findings.

Comment 4

17 years ago
I'm getting similar behavior to this. I'm using build 2001121906 on win2k.

I turned on html send in prefs, then sent several plain text messages.  All of
the messages arrived with no text, and the messages in my sent folder are blank
also.  Checking View, Source, shows no message text, whatever was typed is gone.
I did not try saving the message before sending.

Did not get the message about which way to send (plain/html/both), since it was
plain text.  Recipients are all listed in my address book with "unknown" as
their html choice.





Comment 5

17 years ago
I have the same problem, and might be able to add some details. I'm under 
Win2k, using 0.9.8

The only part of my email message that actually requires HTML is my signature 
(it's an image, I know it's lame, but my employer requires it). When I compose 
an email, I see the image just fine. If I check in Edit - Preferences, under 
Mail & Newsgroups - Send Format, I have selected the "Ask me" option. Under 
Options - Format in the compose window, the selected option is Auto-detect.

But when I send the message, I never get asked which format I would like to 
send the mail as, and I get this as my signature :

-- 
<cid:part1.03070904.09020507@netscape.com>

If I check the message source (Ctrl-U), nothing more is there...

What's weird is that even if I select "Send as plain text and HTML" or "Send as 
HTML only" in the Send Format options, the selection in the Options - Format 
menu in the compose window does not change from Auto-detect, and the image 
still does not show up in the sent message. But if I change the Options - 
Format myself, to "Rich text (HTML)" or "Plain and Rich (HTML) text", the image 
turns out perfect. But that setting is not remembered from one compose to 
another (or perhaps it's initialized from the Send - Format setting, and since 
that one is not correct, it goes to the default).

I even tried to install the latest version of Netscape 6 (6.2.1) to see if it 
had the same problem, and it does.

But the problem doesn't seem to show up on every machine, because it works fine 
for some of my coworkers.

I hope this helps nail down this bug.

Comment 6

17 years ago
WFM Mozilla Build 2002041818 LinuX

Comment 7

16 years ago
Is this still a problem in a current build?

pi

Comment 8

16 years ago
I see 3 bugs mentioned here.

If you don't see any text at all in the sent message, that's surely another bug,
and I never saw that.
If the checkbox in the Options|Format menu in the HTML composer doesn't reflect
your Prefs|Mailnews|Send Format pref, that's another bug as well.

The original bug reported here seems to be: You enable "Compose message in HTML
format" in the Account Settings. But the message is sent in plaintext. Please
correct me, if I misunderstood this bug.

This is not a bug at all, it is a feature. By default, you *compose* the message
in HTML, taking advantage of the rewrapping features in the HTML composer and
giving you the option to style the message, but if the message can be
represented fairly in plaintext, we use that for *sending*. (if there is
fstyling being used, we ask the user what to do, unless we know that the
recipient can recieve HTML.) Otherwise, we would send HTML all the time and that
would pose a major interoperability problem. We try to figure it out for the
user and do the right thing (because the user can't in most cases do it himself,
because of lack of backgkround knowledge).

WONTFIX - works as specified.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 9

16 years ago
ops, I hit invalid, sorry.
Product: Browser → Seamonkey
(In reply to Ben Bucksch (:BenB) from comment #8)
> You enable "Compose message in HTML format" in the Account Settings. But the message is sent in
> plaintext. [...] This is not a bug at all, it is a feature.

12,027 Downloads of "Always HTML" addon (and counting, 245 in the last 30 days), and 1,742 addon users per day's average think otherwise and have decided to switch off {Delivery format: Auto-Detect} because it does the wrong thing for them more often than not.
https://addons.mozilla.org/de/thunderbird/addon/always-html/statistics/?last=30
Summary: HTML mail doesn't send in html. → HTML mail doesn't send in html, sends plain text instead (due to delivery-format: auto-detect)
You need to log in before you can comment on or make changes to this bug.