Closed Bug 1144770 Opened 5 years ago Closed 4 years ago

Homescreen not populated after shallow flash

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

x86_64
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: gmarty, Unassigned)

References

Details

Attachments

(3 files)

After shallow flashing Gecko and Gaia using B2G-Flash-Tool, 90% of the time, the homescreen remains empty with no icons.
This is fixed on reboot.
Naoki, have you seen this? I have noticed this too many times.
Flags: needinfo?(nhirata.bugzilla)
Shallow flashing?  Might be a mismatch of the gonk to the gecko layer; though I'm not 100 % sure.

I haven't shallow flashed on the flame in a while due to the gonk changes that have been occurring with bluetooth / NFC...
Flags: needinfo?(nhirata.bugzilla)
oops.  didn't mean to clear my NI.  Will take a closer look to see if I can repro. 

This would simulate OTA testing ... which right now is up for debate from version to version : see bug 1151006

I think FOTA might be required depending on which version to which version you go to.
Flags: needinfo?(nhirata.bugzilla)
I can't seem to reproduce this issue.

Can you tell me what you're base build is?

Basically the output to :
https://github.com/Mozilla-TWQA/B2G-flash-tool/blob/master/check_versions.py
Flags: needinfo?(nhirata.bugzilla) → needinfo?(gmarty)
I can't replicate at the moment, but I've seen it on a Keon last week.
It's been on for weeks now with a variable reproducibility rate.

I'll update the bug next time I bump into this issue.
Flags: needinfo?(gmarty)
Today I shallow flashed build 20150421010201 on 2 different devices using flash_pvt and I could reproduce this issue on 1 of them:
Build ID               20150421010201
Gaia Revision          a8e4f95dce9db727dda5d408b038f97fb4296557
Gaia Date              2015-04-20 19:30:21
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/7b823253d9f2
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.alex.20150114.113956
Firmware Date          mercredi 14 janvier 2015, 11:40:18 (UTC+0100)
Bootloader             L1TC000118D0
Attached image no-icons.png
Attached file logcat-1.txt
Naoki can you take a look at these? I was able to get both the flash logs and logcat of boot in which this reproduced. Im not 100% sure but it seems to be i think a mounting problem. I dont think it can read the files in which things are held.
Flags: needinfo?(nhirata.bugzilla)
Attached file log-1.txt
Flags: needinfo?(nhirata.bugzilla)
See Also: → 1187743
Mass update: Resolve wontfix all issues with legacy homescreens.

As of 2.6 we have a new homescreen and having these issues open is confusing. All issues will block bug 1231115 so we can use that to re-visit any of these if needed.
Blocks: 1231115
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.