[Settings][sound][text selection] Text selection elements are present on the create ringtone screen allowing user to get text selection carets around the play/pause button

VERIFIED FIXED in 2.2 S9 (3apr)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: jmitchell, Assigned: pdahiya)

Tracking

unspecified
2.2 S9 (3apr)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing])

Attachments

(2 attachments)

Reporter

Description

4 years ago
Description:
On the create ringtone page you are able to long press the screen and bring up text selection options. This is resulting in a variety of poor looking elements such as the carets around the play/pause button. I was also able to get the carets to turn yellow when dragging them around. Once I was able to bring up the select all, copy and paste options but the options are usually not available


Repro Steps:
1) Update a Flame to 20150318055750
2) Launch settings > sound > Manage tones and select the + in the upper right
3) Select any song from the list and tap done
4) Long press on elements on the Create Ringtone screen

Actual:
Text selection elements are present on this screen

Expected:
Text selection will not be available here 
-or-
Text selection will be confined to text only (or things that can be successfully cut and pasted)

Environmental Variables:
Device: Flame Master
Build ID: 20150318055750
Gaia: b8051d370ddf4e5bd8e7d8a19fb9eeb5fd6ffb39
Gecko: 41a61514461e
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 39.0a1 (Master)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0


Repro frequency: 6/6
See attached: screenshot
Reporter

Comment 1

4 years ago
This issue also repros in 2.2; text selection was not implemented prior to 2.2

Device: Flame 2.2 (KK - Nightly - Full Flash - 319mem)
Build ID: 20150318055750
Gaia: b8051d370ddf4e5bd8e7d8a19fb9eeb5fd6ffb39
Gecko: 41a61514461e
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 39.0a1 (Master)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Reporter

Updated

4 years ago
Summary: Summary (title) Field: [Settings][sound][text selection] Text selection elements are present on the create ringtone screen allowing user to get text selection carets around the play/pause button → [Settings][sound][text selection] Text selection elements are present on the create ringtone screen allowing user to get text selection carets around the play/pause button
NI on CCP component owner for nomination decision and assignment.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga) → needinfo?(gchang)
NI EPM for this issue.
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][COM=Text Selection]
Flags: needinfo?(gchang) → needinfo?(hochang)

Comment 4

4 years ago
This should be block as text selection should not be enabled in this case.

Hi Punam, the issue is similar to bug 1127529, do you mind to help on this? Thanks.
blocking-b2g: --- → 2.2?
Component: Gaia::Settings → Gaia::Ringtones
Flags: needinfo?(hochang) → needinfo?(pdahiya)
See Also: → 1127529
Assignee

Comment 5

4 years ago
(In reply to howie [:howie] from comment #4)
> This should be block as text selection should not be enabled in this case.
> 
> Hi Punam, the issue is similar to bug 1127529, do you mind to help on this?
> Thanks.

That's right, the issue is similar to bug 1127529, assigning myself to submit fix to disable text selection by default for create ringtone flow. Thanks!
Flags: needinfo?(pdahiya)
Assignee

Updated

4 years ago
Assignee: nobody → pdahiya
Assignee

Comment 7

4 years ago
Comment on attachment 8581693 [details] [review]
[gaia] punamdahiya:Bug1144796 > mozilla-b2g:master

Hi Jim

Attached patch disables text selection on create ringtone screen. Please review. Thanks!
Attachment #8581693 - Flags: review?(squibblyflabbetydoo)
Comment on attachment 8581693 [details] [review]
[gaia] punamdahiya:Bug1144796 > mozilla-b2g:master

I'm pretty sure you can use `html` instead of `*` for your CSS selector here. That should have better performance.
Attachment #8581693 - Flags: review?(squibblyflabbetydoo) → review-
Assignee

Comment 9

4 years ago
(In reply to Jim Porter (:squib) from comment #8)
> Comment on attachment 8581693 [details] [review]
> [gaia] punamdahiya:Bug1144796 > mozilla-b2g:master
> 
> I'm pretty sure you can use `html` instead of `*` for your CSS selector
> here. That should have better performance.

Hi Jim

Is there any way to test the above css selector html vs * for performance, I am not sure how to test it out.  Patch attached follows the consistent pattern followed by other gaia apps. See meta bug 1092944 for fixes in Settings, browser, email, calendar and all media apps. 

Thanks
Flags: needinfo?(squibblyflabbetydoo)
There's probably not an easy way (and I doubt the pages in question are complicated enough for it to make a huge difference). However, I grepped the gaia tree and about half of the apps do things the way I suggested. Unless that way breaks things, I think we should prefer it.
Flags: needinfo?(squibblyflabbetydoo)
Assignee

Comment 11

4 years ago
Comment on attachment 8581693 [details] [review]
[gaia] punamdahiya:Bug1144796 > mozilla-b2g:master

Setting review flag on PR updated with review feedback.
Attachment #8581693 - Flags: review- → review?(squibblyflabbetydoo)

Updated

4 years ago
Attachment #8581693 - Flags: review?(squibblyflabbetydoo) → review+
Assignee

Updated

4 years ago
Keywords: checkin-needed
http://docs.taskcluster.net/tools/task-graph-inspector/#e72bIlCrSMa3wsM5V5XK2A

The pull request failed to pass integration tests. It could not be landed, please try again.
Marking as 2.2+ because this really ugly.
blocking-b2g: 2.2? → 2.2+
Assignee

Updated

4 years ago
Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Assignee

Comment 15

4 years ago
Comment on attachment 8581693 [details] [review]
[gaia] punamdahiya:Bug1144796 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Not a regression
[User impact] if declined:  Create Ringtone screen will have text selectable and blue text carets appear on long press 
[Testing completed]: On master
[Risk to taking this patch] (and alternatives if risky): Very low
[String changes made]: None
Attachment #8581693 - Flags: approval-gaia-v2.2?(bbajaj)
Attachment #8581693 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
This issue is verified fixed on Flame Master and 2.2.

Result: Text selection is not available when long-pressing any elements on the Create Ringtone screen.

Environmental Variables:
Device: Flame 3.0 (KK, 319mb, full flash)
Build ID: 20150402063750
Gaia: f37be8b44cb7c3a147b9615ab76743b760f08eeb
Gecko: 35046df9df1f
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Environmental Variables:
Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20150401162503
Gaia: 1ceca464053dee4a8bf10ea5abeef724d68c2ff2
Gecko: 427b4da96714
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][COM=Text Selection] → [QAnalyst-Triage?][COM=Text Selection]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][COM=Text Selection] → [QAnalyst-Triage+][COM=Text Selection]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.