Closed Bug 1144827 Opened 5 years ago Closed 5 years ago

Right mouse button click doesn't work properly when selecting items from mouse menu

Categories

(Core :: Widget: Win32, defect, major)

39 Branch
x86_64
Windows 7
defect
Not set
major

Tracking

()

VERIFIED FIXED
mozilla39
Tracking Status
firefox38 --- unaffected
firefox39 + verified

People

(Reporter: Virtual, Assigned: dvander)

References

Details

(Keywords: nightly-community, regression)

Attachments

(1 file, 1 obsolete file)

STR:
1. Right click mouse button on some site in non specific space to show up a menu.
2. Select for example "Bookmark This Page" with right click.
3. Nothing will happen.


It's probably a similar regression from bug #1143567, like in was bug #1144081.


[Tracking Requested - why for this release]: Regression


@ David Anderson [:dvander] - Could you look on this issue?
Flags: needinfo?(dvander)
Duplicate of this bug: 1144942
Component: Toolbars and Customization → Widget: Win32
Product: Firefox → Core
Right-click on 'forward/back' arrow does not produce the history list.  No errors in Browser Console.
Oops, I posted wrong bug
Please ignore comment #3
Attachment #8579718 - Attachment is obsolete: true
Also happens on my ASUS x64 laptop, no special kbd, etc.
I don't think the expression describes all the situation. On my computer, now I can left click on bookmark menu, but if I want to right click on a special bookmark to let a context menu show on it nothing happens.
(In reply to leichixian from comment #6)
> I don't think the expression describes all the situation. On my computer,
> now I can left click on bookmark menu, but if I want to right click on a
> special bookmark to let a context menu show on it nothing happens.

I can repo this as well.

str: try to right-click any bookmark in a menu in chrome
Used to work fine prior to the 3-18 Nightly. I saved the installer for that, and uninstall the 3-18 and reinstall that Nightly, R-click on my bookmarks in folders pops up their context menu. Something broke this functionality.
(In reply to Jim Mathies [:jimm] from comment #7)
> str: try to right-click any bookmark in a menu in chrome

WFM
Nothing happens when you open menu on bookmark with right mouse button and want to select the item with also right mouse button.
Right clicking doesn't work at least on all bookmark folders, the bookmark menu button and Adblock plus button in the toolbar.
Attached patch fixSplinter Review
Urgh. Sorry about that, another case of nsEventStatus -> bool. I checked the other callers to make sure I didn't make the same mistake elsewhere this time.
Assignee: nobody → dvander
Status: NEW → ASSIGNED
Flags: needinfo?(dvander)
Attachment #8580202 - Flags: review?(jmathies)
Comment on attachment 8580202 [details] [diff] [review]
fix

I wonder why our tests did such a lousy job of picking up on this? This affected native event dispatching only maybe?
Attachment #8580202 - Flags: review?(jmathies) → review+
(In reply to Jim Mathies [:jimm] from comment #12)
> Comment on attachment 8580202 [details] [diff] [review]
> fix
> 
> I wonder why our tests did such a lousy job of picking up on this? This
> affected native event dispatching only maybe?

Yeah, all our tests use purely synthetic dispatch. Kats mentioned we should transition tests to synthesize native widget events instead. I think that's a good idea since it would catch bugs like these. We could do it one widget at a time, too (I might try it just for Windows, after apz bugs are done).
Duplicate of this bug: 1145381
https://hg.mozilla.org/mozilla-central/rev/4510d4116527
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Confirmed fixed as of 2015-03-19 39.0a1 on 64x Win 7 SP1.
You need to log in before you can comment on or make changes to this bug.