Contacts header is not localized

VERIFIED FIXED in Firefox OS master

Status

Firefox OS
Gaia::Contacts
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: ferjm, Assigned: gandalf)

Tracking

({regression})

unspecified
2.2 S10 (17apr)
All
Gonk (Firefox OS)
regression
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
As you can see in the attached screenshot, the contacts app header is no longer localized.

I suspect bug 1098673 might have caused this.
(Reporter)

Comment 1

3 years ago
Created attachment 8579570 [details]
contacts.png
(Reporter)

Updated

3 years ago
Depends on: 1098673
That's weird.  I can see the string here:

https://github.com/mozilla-b2g/gaia/blob/c39e15f631de80c69467fda0d4ea0bcda9e194ca/apps/communications/contacts/locales/contacts.en-US.properties#L10

Could this be related to the gaia-header web component at all?
QA wanted for a branch check
Keywords: qawanted, regression
FWIW, I can't reproduce this on master.
I could reproduce on today's nightly on trunk. For built-in apps this seems to only occur on Contacts. I filed bug 1144433 one day before comment 0, so I know at least for Accented English that this is a recent regression.

Device: Flame 3.0 (nightly eng, full flash)
BuildID: 20150320010204
Gaia: 8837f94418d69a0b06c1f4843b0779e2bb72165a
Gecko: 4d2d97b3ba34
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

--------

This issue does not affect Flame 2.2. Accented English is displayed for Contacts app.

Device: Flame 2.2 (nightly eng, full flash)
BuildID: 20150316002502
Gaia: a6b2d3f8478ec250beb49950fecbb8a16465ff6f
Gecko: 18619f8f6c5c
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
[Blocking Requested - why for this release]: Regression
blocking-b2g: --- → 3.0?
triage: basic function broken
blocking-b2g: 3.0? → 3.0+
(Reporter)

Updated

3 years ago
Blocks: 1148654
Blocks: 1144433
(Reporter)

Comment 8

3 years ago
Hey Stas, did you manage to reproduce this issue?

I could reproduce it with the latest master on my local clone and from a clean gaia downloading it as a zip package from https://github.com/mozilla-b2g/gaia/archive/master.zip I have no l10n related environment variables like the ones described at https://developer.mozilla.org/en-US/Firefox_OS/Building#Building_multilocale
Flags: needinfo?(stas)
It looks like this has always been broken and bug 1098673 only exposed it :(  The proper fix is bug 1066347 which Zibi has already started working on today.
Flags: needinfo?(stas)
(Reporter)

Updated

3 years ago
Depends on: 1066347
(Assignee)

Comment 10

3 years ago
It seems fixed with the landing from 1066347.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Assignee: nobody → gandalf
status-b2g-master: affected → fixed
Target Milestone: --- → 2.2 S10 (17apr)
This issue is verified fixed on Flame Master.

Result: Contacts header is localized. (checked in Arabic, Russian, Accented English)

Environmental Variables:
Device: Flame 3.0 (KK, 319mb, full flash)
Build ID: 20150501010203
Gaia: 759a1f935a6a81c32ad66e39a6353b334dfa4f91
Gecko: 7723b15ea695
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-master: fixed → verified
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
status-b2g-v2.5: --- → verified
status-b2g-v2.5: verified → ---
You need to log in before you can comment on or make changes to this bug.