[Contacts] Taking a 'Contact Photo' from Camera displays "Close" text that overlaps with screen height (portrait) and capture/shutter button (landscape).

RESOLVED DUPLICATE of bug 1144733

Status

RESOLVED DUPLICATE of bug 1144733
4 years ago
4 years ago

People

(Reporter: onelson, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.2 unaffected, b2g-master affected)

Details

(Whiteboard: [3.0-Daily-Testing])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8579575 [details]
contacts_camera_close_sharetext.jpg

Description:
When the user attempts to take a new photo for a contact(either through new contact, or editting an existing one) through a share activity through camera, they will observe that the "close" text that propogates with the 'X' UI (not within app outside of a share activity), they will observe the text produces some overlapping issue with surrounding UI elements. In portrait mode it will be partially chipped by the bottom of the screen; in landscape, it will overlap with the shutter/capture button.


Repro Steps:
1) Update a Flame to 20150318055750
2) Open the 'Contacts' app.
3) Create a new contact.
4) Tap the large "+" to add a new contact photo.
5) Tap 'Camera' to open camera share activity.
6) Observe the "close" text.
7) Rotate phone between landscape and portrait and observe text.

Actual:
"Close" text overlaps surrounding UI elements.

Expected:
"Close" text does not overlap UI.
Potentially not necessary on screen.


Environmental Variables:
--------------------------------------------------
Device: Flame 3.0
Build ID: 20150318055750
Gaia: b8051d370ddf4e5bd8e7d8a19fb9eeb5fd6ffb39
Gecko: 41a61514461e
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0


***********************************************
Issue DOES NOT REPRO on flame 2.2 devices
Results: "Close" text is not present while sharing camera from contacts; only an 'X' to leave share activity.

Device: Flame 2.2
BuildID: 20150318002504
Gaia: 306772a58335ac4cad285d27c3805090a8cc6886
Gecko: a6f5f4035ea5
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
--------------------------------------------------

Repro frequency: 5/5
See attached: 
screenshot
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Whiteboard: [3.0-Daily-Testing]
(Reporter)

Comment 1

4 years ago
Missed the bug, looked in the wrong component due to share activity. Resolving as dupe of 1144733
Status: NEW → RESOLVED
Last Resolved: 4 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Keywords: regression
Resolution: --- → DUPLICATE
Duplicate of bug: 1144733
You need to log in before you can comment on or make changes to this bug.