Add NSIS 3.0b1 to Mozilla Build and remove NSIS 3.0a2

RESOLVED FIXED

Status

mozilla.org
MozillaBuild
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: rstrong, Assigned: rstrong)

Tracking

Details

Attachments

(1 attachment, 1 obsolete attachment)

Since NSIS 3.0a2 hasn't been deployed to the build systems we are going to go with NSIS 3.0b1 on the build systems and Mozilla Build
bug 1144934 will add it to configure.in
Created attachment 8579669 [details] [diff] [review]
patch
Attachment #8579669 - Flags: review?(ryanvm)
Comment on attachment 8579669 [details] [diff] [review]
patch

Review of attachment 8579669 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM with the one comment addressed. Have you tested this locally or did you want me to give it a spin as well?

::: packageit.sh
@@ +144,5 @@
> +pushd "${MSYS_STAGEDIR}/mozilla-build/nsis-3.0b1"
> +mv makensis.exe makensis-3.0b1.exe
> +mv Bin/makensis.exe Bin/makensis-3.0b1.exe
> +popd
> +

Please add this to the "Install other non-MSYS packages" section instead (under the yasm install or something).
Attachment #8579669 - Flags: review?(ryanvm) → review+
Created attachment 8579753 [details] [diff] [review]
patch with comments addressed

Found the extraction path was incorrect while testing and with that fixed it works. :)
Attachment #8579669 - Attachment is obsolete: true
Attachment #8579753 - Flags: review+
Pushed to mozilla-build
https://hg.mozilla.org/mozilla-build/rev/758c08908381
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Blocks: 989531
You need to log in before you can comment on or make changes to this bug.