Closed Bug 1144942 Opened 7 years ago Closed 7 years ago

Right-clicking on bookmark-toolbar SUBmenu item to edit its properties doesn't work

Categories

(Firefox :: Untriaged, defect)

39 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1144827

People

(Reporter: cud, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150318055750

Steps to reproduce:

Right-click on a bookmark to edit its properties


Actual results:

No response


Expected results:

Properties drop-down menu should appear. DOES work with Menu hotkey button.
This is the March 18th 38.0a1 Nightly. It also happens when clicking on a bookmark-toolbar parent menu, which can't be edited unless using the Win Menu keyboard key.
Hardware: x86 → x86_64
Summary: Right-click on bookmark-toolbar to edit its properties doesn't work → Right-clicking on bookmark-toolbar item to edit its properties doesn't work
Summary: Right-clicking on bookmark-toolbar item to edit its properties doesn't work → Right-clicking on bookmark-toolbar SUBmenu item to edit its properties doesn't work
Clarification: Right-clicking on a root-level Bookmarks Toolbar bookmark to invoke its context menu works fine. It's a bookmark in a toolbar's SUBmenu that can't be right-clicked for its CM. To replicate, create a submenu with a R-click on the Bookmarks Toolbar, then create a plain bookmark in that new submenu, and try to invoke its CM via R click: no response. Menu-key actuation on it while it has focus, works. R-click handling of toolbar items seems generally flaky.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1144827
Confirmed fixed as of 2015-03-19 39.0a1 on 64x Win 7 SP1.
You need to log in before you can comment on or make changes to this bug.