If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Page doesn't stop loading even though debugging shows it's finished

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
3 years ago
a year ago

People

(Reporter: Ray Satiro, Unassigned)

Tracking

39 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8579791 [details]
20150318_2218_41.avi

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150315030236

Steps to reproduce:

Go to the bug (unrelated) here:

https://bugzilla.mozilla.org/show_bug.cgi?id=1144992

Click on the attachment gif, then click the back mouse button, and repeat until the page appears to be waiting to finish loading.


Actual results:

The page doesn't stop loading. This issue right now in this session is reproducible. I have a fairly clean profile here that I have been using all day, however I cannot reproduce this in a just-born clean profile. In the affected profile I have no extensions and only H264 plugin.

I enabled a debugging proxy and I can see the right information is returned so I don't know why Nightly doesn't properly acknowledge the load. This happens in both e10s and non-e10s tabs.

What's very interesting is the second I turn on web developer tools (if they were not on) or turn them off (if they were on) the image will appear and the page load will complete. I tried this several dozen times at arbitrary times waiting for the page to load I would hit CTRL+SHIFT+I and the image would show. Another way to get the image to show and the page load to complete is to select another window.

I made a video showing the problem. It is confusing that there are two mouse pointers in the video and that is because the GIF image that is loaded actually has a mouse pointer in it. The actual mouse pointer in my video has a transparent yellow circle around it. The video is attached.

I will also be attaching a Fiddler capture of the session. Session #46 is the completed session that doesn't finish loading. Notice the CONNECT in session 47 and the reget in 48 when the page loads (ie the gif is shown).


Expected results:

This shouldn't happen obviously.
(Reporter)

Comment 1

3 years ago
Created attachment 8579792 [details]
firefox nightly page doesn't stop loading.saz
Hi Ray,

I didn't managed to reproduce this issue on my end. I've tested on the latest release(43.0) and latest Nightly(46.0a1). The page completely loaded every time I opened it.

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20151208100201

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID: 20151216030229

Can you please try to reproduce this on your end using the latest release(43.0) and latest Nightly(46.0a1) with a new Firefox profile (maybe safe mode activated) and provide the results? Sometimes custom settings or installed add-ons can provoke this kind of issues.
https://support.mozilla.org/en-US/kb/troubleshoot-and-diagnose-firefox-problems

Thanks,
Paul.
Flags: needinfo?(raysatiro)
(Reporter)

Comment 3

2 years ago
Then and now I cannot reproduce this in a just-born profile. I tried to reproduce in my regular nightly profile today with no add-ons or plugins but was unable.

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID: 20151217072309
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(raysatiro)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.