Firefox hangs. in unkillable process on Windows 7 32bit. Can kill even as admin.

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: mavinkai, Unassigned)

Tracking

36 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8579815 [details]
firefox.png

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150305021524

Steps to reproduce:

Browse normally opening multiple tabs. Around a 100 tabs are opened from a session restore. None are active. Normal browsing continues. Around when 10 tabs are active (new or session restored) suddenly firefox hangs unkillable. Cant kill with any task manager


Actual results:

Around when 10 tabs are active (new or session restored) suddenly firefox hangs unkillable. Cant kill with any task manager. Happened only with Firefox 36 after recent windows update. Never happened before.

Can open new tabs. But progress indicator just keeps circling. No other progress happens in loading the page. Crash reporter eventually reports a crash. But cant kill process.


Expected results:

The page should load. At least firefox should be killable. I strongly suspect the latest windows update is responsible. However am not able to figure it out. Only McAfee antivirus is running. There is no firewall. A lot of people have reported earlier issues with various other firewalls/antivirii here in this thread http://forums.mozillazine.org/viewtopic.php?f=23&t=2882597&sid=faba613d10654b368efa8d7a32721f56&start=15 and some people are experiencing problems with the latest update to 36. Maybe this is a regression bug.

Attaching a screenshot of process explorer. Firefox hangs in ntdll.dll at !_get_flsindex+0x6
An unkillable process is usually a bug in some driver.
http://blogs.technet.com/b/markrussinovich/archive/2005/08/17/unkillable-processes.aspx
I could be your networking driver or the driver that McAfee installs but the trigger for this could be a recent change in Firefox.
Can you try https://bugzilla.mozilla.org/show_bug.cgi?id=1124880#c35 ?
Flags: needinfo?(mavinkai)
(Reporter)

Comment 2

4 years ago
I looked at that. It doesnt seem to indicate a kernel mode crash. In any case this machine has been stable running FF for more than 3 years now without any problems. 

I cant even attach a debugger to the process since its stuck in kernel mode (I assume)  - at least windbg refuses to attach to it. And kernel mode debugging requires bcdedit.

It is something to do with hello and UDP? See this http://stackoverflow.com/questions/5300295/how-to-resolve-a-freeze-or-deadlock-in-ntdll-dll

Can I do a crash dump and debug the dump?
(Reporter)

Comment 3

4 years ago
Appears to be fixed in FF 36.0.4. Firefox autoupdated after a kernel mode hang forced a reboot. Even though I was running it in the windbg when the 36.0.1 went into the kernel mode hang, I was unable to capture anything of use, because child debug had not been set. So far havent faced the unkillable problems 36.0.4. Firefox did crash on an out of memory error triggered prima facie it appears due to flashblock. But otherwise no problems so far.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(mavinkai)
Resolution: --- → WORKSFORME

Comment 4

4 years ago
I am on Windows 7 x64 with latest Firefox 36 and it still happens here. I did some kernel debuging like descriped here: http://blogs.technet.com/b/markrussinovich/archive/2005/08/17/unkillable-processes.aspx
And figured out that this is caused by a windows driver afd.sys (Ancillary Function Driver). 

So this is the driver that causes the hang and the broken website loading.

Comment 5

4 years ago
Here is the debug output: https://pastebin.mozilla.org/8827164
You need to log in before you can comment on or make changes to this bug.