EME shaker shakes every time I switch tabs when playing the first EME video

RESOLVED WONTFIX

Status

()

Firefox
General
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: cpeterson, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
STR:
1. Reset "browser.eme.ui.firstContentShown" pref to false.
2. Start watching a DRM video using the Adobe or ClearKey CDM.
3. See the shaker icon shake.
4. Without stopping the video, switch tabs away then back to the video.

RESULT:
The shaker icon shakes again. It will shake every time you switch tabs until you unload the page watching your first DRM video.

* Sevaan or Javaun: is this the expected behavior of the shaker icon?
Flags: needinfo?(sfranks)
No, this is not the expected behaviour. Once it shakes, it should never shake again. Good catch.
Flags: needinfo?(sfranks)
Does this happen even if you let the animation finish?
Flags: needinfo?(cpeterson)
(Reporter)

Comment 3

3 years ago
Yes. If I open about:config in another tab, I can see the browser.eme.ui.firstContentShown pref flip to 'true' when the shaker animation finishes, but the icon still shakes with I switch back to the video tab.

Is the original pref value being cached somewhere?
Flags: needinfo?(cpeterson)
(In reply to Chris Peterson [:cpeterson] from comment #3)
> Yes. If I open about:config in another tab, I can see the
> browser.eme.ui.firstContentShown pref flip to 'true' when the shaker
> animation finishes, but the icon still shakes with I switch back to the
> video tab.
> 
> Is the original pref value being cached somewhere?

No, the node will probably just stay there but be hidden, and layout restarts the CSS-based animation when the node is reshown (because the item's frame will have been destroyed and then gets recreated when it's no longer display: none).

I would prefer to wontfix this. I don't think it's worth the code complexity to try to cope with this and remove the attribute again. Realistically, very very very few if any people will actually hit this bug.
(Reporter)

Comment 5

3 years ago
OK. It is a little annoying but you are correct that few regular users will actually see the bug. I see it because I have been testing multiple user profiles.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.