[B2G][3rd party app] Here Maps is unable to show current location,when use tap on current location green key

RESOLVED WONTFIX

Status

Tech Evangelism
Preinstalled B2G Apps
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: Peipei Cheng (needinfo if you need my action), Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
x86
Windows 7

Firefox Tracking Flags

(b2g-v2.1 unaffected, b2g-v2.1S affected)

Details

(Whiteboard: [sprd403379])

This bug is detected by partner on dolphin 2.1s.

(a) start navigation from current location to another location using 'Here Map'app.
(b) slide map to view near route in map.
(c) press current location green key.
    --> Sometimes DUT can not show the current location pointer automatically. 

Partner already checked that the network condition was fine. So it is unreasonable that HereMaps cannot show current location.



slog and video can be found here: 
https://drive.google.com/folderview?id=0B8zFbzIptpVDfnUwQXpDWDdweXhETldaWVVZaU9ldy1Hc2Z2aUpVMDZqUmZlT2JKaHZ2M1k&usp=sharing
Whiteboard: [sprd403379]

Comment 1

3 years ago
I was not able to reproduce this issue on a Flame running 2.1; Here Maps returned to my current location successfully on all attempts.
(frequency 0/7)


@ Peipei - What was the frequency of this issue on your end?

Updated

3 years ago
Blocks: 837298

Updated

3 years ago
Flags: needinfo?(pcheng)
(In reply to Michael Ellis from comment #1)
> I was not able to reproduce this issue on a Flame running 2.1; Here Maps
> returned to my current location successfully on all attempts.
> (frequency 0/7)
> 
> 
> @ Peipei - What was the frequency of this issue on your end?

Michael, 
Thank you very much for looking into this. Actually, we could not reproduce on Flame.
Partner can only reproduce this bug on their device. And the reproduce rate is 3/5 according to their test.
status-b2g-v2.1: --- → unaffected
status-b2g-v2.1S: --- → affected
Flags: needinfo?(pcheng)

Comment 3

3 years ago
Unfortunately, we must be able to reproduce the issue on reference hardware in-order to reach out to the developer for a resolution.  

Closing this bug as a device specific issue.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX

Comment 4

3 years ago
(In reply to Michael Ellis from comment #3)
> Unfortunately, we must be able to reproduce the issue on reference hardware
> in-order to reach out to the developer for a resolution.  
> 
> Closing this bug as a device specific issue.

Hi Michael,

Thank you for your help to Investigate the third app issue.

But for this issue,though we can not reproduce(even I can not reproduce with dolphin),our QA could reproduce it every time.
Our engineer have checked that when issue occur,GPS could get the position correctly,But we can see from the video that the green key does not work.

Could you help to contacts the third app owner and give us some suggestion for what is wrong with the 'green key'??

Thank you!!
Flags: needinfo?(mellis)

Comment 5

3 years ago
Although we would love to be able to facilitate this request, it would be overwhelming to the app partner to provide support for every instance of every build, device, & local. Because this issue is occurring on the specific partner build, but not on other builds or devices; it is our policy not to reach out to the developer for resolution.
Flags: needinfo?(mellis)
You need to log in before you can comment on or make changes to this bug.