[Wifi]Can't connect a WIFI network again after forgetting the password.

RESOLVED DUPLICATE of bug 1123680

Status

Firefox OS
Wifi
RESOLVED DUPLICATE of bug 1123680
3 years ago
3 years ago

People

(Reporter: Coler, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: 2.2-nexus-5-l)

Attachments

(2 attachments)

2.84 MB, video/mp4
Details
377.61 KB, text/plain
Details
(Reporter)

Description

3 years ago
Created attachment 8579922 [details]
1646.MP4

[1.Description]:
[Nexus 5][v2.2&v3.0][Flame2.2]Forget a connected network, and tap it before the "offline" disaapearing quickly.then trys to connect it again, the network can't be connected successfully.

Found time:16:46
Attachmnent:logcat_1646.txt,1646.mp4

[2.Testing Steps]: 
1. Launch Settings.
2. Tap WIFI and connect a network which need a password.
3. Tap the connected network->"Forget".
**It will prompt "offline" under the name for one second.
4. Tap  previous network again quickly.(Before the "offline" disappears.)
**Nothing happens at this time.
5. Tap  previous network third time, and input password.

Note:
1. If we  turn off ->turn on WIFI, it will connect autoamtically.
2. If we connect other network after STEP 4, it will be normal.

[3.Expected Result]: 
5. Network should connect successfully at any time.

[4.Actual Result]: 
5. The network can't be connected successuflly.

[5.Reproduction build]: 

N5_3.0(affected):

Build ID               20150318055750
Gaia Revision          b8051d370ddf4e5bd8e7d8a19fb9eeb5fd6ffb39
Gaia Date              2015-03-18 07:48:50
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/41a61514461e
Gecko Version          39.0a1
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150318.093541
Firmware Date          Wed Mar 18 09:35:58 EDT 2015
Bootloader             HHZ12d

N5_2.2(affected):

Build ID               20150318002504
Gaia Revision          306772a58335ac4cad285d27c3805090a8cc6886
Gaia Date              2015-03-17 17:12:36
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/a6f5f4035ea5
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150318.040241
Firmware Date          Wed Mar 18 04:02:56 EDT 2015
Bootloader             HHZ12d

Flame 2.2(affected):

Build ID               20150318002504
Gaia Revision          306772a58335ac4cad285d27c3805090a8cc6886
Gaia Date              2015-03-17 17:12:36
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/a6f5f4035ea5
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150318.040534
Firmware Date          Wed Mar 18 04:05:45 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test

[8.Note]:
It CAN be repro on Flame2.2
(Reporter)

Comment 1

3 years ago
Created attachment 8579923 [details]
logcat_1646.txt
Hi Gerry, please help with this, thank you
Flags: needinfo?(gchang)
Here are my steps:

1. Factory reset dut.
2. Put in the wrong password for a WiFi connection in the FTU and keep hitting next to reach the homescreen. 
3. Open the settings app and then tap on "WiFi". 
4. Tap on the same WiFi connection used in step 2 and tap "Forget".
5. Tap on the same WiFi connection again and put in the correct password. 

Notice the wifi connection is not connected to even though the user put in the right password.

6. Restart the phone.

Notice the user is now connected to that WiFi connection.
status-b2g-master: --- → affected
Nominating this 2.2? because this is a bad user experience. 

WiFi will appear to be broken if the user puts in the wrong password during the FTU and then tries to correct the password in settings.
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage+]
In my testing, I can't enter the password in step 5 of comment #3. It will still use the wrong password to connect.

The build I use is 
Build ID               20150322162502
Gaia Revision          44c62060581fde8de1e12e94cf55e9673b401a47
Gaia Date              2015-03-20 19:05:17
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/e6140a32902a
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2

NI developer for investigation.
Hi Vincent,
Can you help to dispatch?
Flags: needinfo?(gchang) → needinfo?(vchang)
This seems duplicated to Bug 1123680.
Flags: needinfo?(vchang)
This might be related to bug 1123680 which has been resolved as fixed today by backout. Adding qawanted to check this on tomorrow's build.
QA Whiteboard: [QAnalyst-Triage+]
Keywords: qawanted
This issue does reproduce on today's Flame 3.0

On step 4 of comment 3 user had to tap the connection multiple times to get to that connection's status page. Once user pressed forget, then tapped and entered correct password, the wifi did not automatically connect. Wifi was connected on phone reboot.

Device: Flame 3.0
Build ID: 20150401010204
Gaia: 03164bd160809747e6a198e0dba1b7c3ee7789f5
Gecko: 18a8ea7c2c62
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
Status: NEW → RESOLVED
blocking-b2g: 2.2? → ---
Last Resolved: 3 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Resolution: --- → DUPLICATE
Duplicate of bug: 1123680
You need to log in before you can comment on or make changes to this bug.