[Flame] Unable to place call with one SIM card in second SIM slot

VERIFIED FIXED in Firefox 39, Firefox OS master

Status

Firefox OS
RIL
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: gerard, Assigned: aknow)

Tracking

({regression})

unspecified
2.2 S9 (3apr)
ARM
Gonk (Firefox OS)
regression
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.5+, firefox39 fixed, b2g-v2.2 unaffected, b2g-master verified)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
STR:
 0. Insert one SIM card in second SIM slot
 1. Boot
 2. Place a call

Expected:
 Call is placed

Actual:
 An error about invalid phone number pops

Reproduced on several master builds, maybe since several weeks, on Flame, with multiple SIM cards.

Outgoing SIM card is properly configured to second SIM in SIM manager.
(Reporter)

Updated

3 years ago
Flags: needinfo?(jlorenzo)
[Blocking Requested - why for this release]: Major regression which can lead to a certification blocker.

Reproduced on latest master[1] but not on 2.2[2]

[1] Build ID               20150318160209
Gaia Revision          c39e15f631de80c69467fda0d4ea0bcda9e194ca
Gaia Date              2015-03-18 19:30:04
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/09f6642f7d24
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150318.195921
Firmware Date          Wed Mar 18 19:59:32 EDT 2015
Bootloader             L1TC000118D0

[2] Build ID               20150319002500
Gaia Revision          9043c11f699c15bb6072422d1dad6518d1b5ddda
Gaia Date              2015-03-19 01:40:44
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c0442d170bec
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150319.042028
Firmware Date          Thu Mar 19 04:20:38 EDT 2015
Bootloader             L1TC000118D0
blocking-b2g: --- → 3.0?
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
Flags: needinfo?(jlorenzo)
Keywords: regressionwindow-wanted
Created attachment 8579967 [details]
ril-enabled logcat
QA Contact: ychung
There are 2 different issues with this bug. One is showing the invalid phone number error message, and the other is not making a phone call. I found the window based on the latter, but builds before the first broken build displayed the error message BEFORE the outgoing callscreen shows up and actually making a phone call.

And I double-checked on 2.2, and the issue did NOT reproduce on 2.2. However, the patch for bug 1135268 seems to be uplifted on both 2.2 and Master. But my regression window directs that the cause of this issue is bug 1135268.

===========================================
b2g-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame 3.0
BuildID: 20150301215524
Gaia: 52e12d99ed1533aaa53e3bfb82e94c6b46ca5bab
Gecko: c3cf47629bb4
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

First Broken Environmental Variables:
Device: Flame 3.0
BuildID: 20150301224624
Gaia: 52e12d99ed1533aaa53e3bfb82e94c6b46ca5bab
Gecko: 214e70c97fcc
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Last Working Gaia First Broken Gecko: Issue DOES reproduce 
Gaia: 52e12d99ed1533aaa53e3bfb82e94c6b46ca5bab
Gecko: 214e70c97fcc

First Broken Gaia Last Working Gecko: Issue does NOT reproduce
Gaia: 52e12d99ed1533aaa53e3bfb82e94c6b46ca5bab
Gecko: c3cf47629bb4

http://hg.mozilla.org/integration/b2g-inbound/pushloghtml?fromchange=c3cf47629bb4&tochange=214e70c97fcc

possibly caused by bug 1135268
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
QA Contact: ychung
Szu-Yu, can you take a look at this please? Looks like the landing for bug 1135268 might have caused this.
Blocks: 1135268
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(szchen)
(Assignee)

Comment 5

3 years ago
Sorry, my bad.  It's indeed a stupid defect cause by bug 1135268.

Because of the difference of code base, the patch applied on 2.2 is not exactly same with which on master. I've confirmed that the defect doesn't appear on 2.2.  Thus, the issue is not reproducible on 2.2
Assignee: nobody → szchen
Flags: needinfo?(szchen)
(Assignee)

Comment 6

3 years ago
Created attachment 8580478 [details] [diff] [review]
Fix defect for calling isEmergencyOnly
Attachment #8580478 - Flags: review?(htsai)
Comment on attachment 8580478 [details] [diff] [review]
Fix defect for calling isEmergencyOnly

Review of attachment 8580478 [details] [diff] [review]:
-----------------------------------------------------------------

Thank you.

Though it might require emulator support first, do you think we can add a test case for this?
Attachment #8580478 - Flags: review?(htsai) → review+
(Assignee)

Comment 8

3 years ago
(In reply to Hsin-Yi Tsai [:hsinyi] from comment #7)
> Comment on attachment 8580478 [details] [diff] [review]
> Fix defect for calling isEmergencyOnly
> 
> Review of attachment 8580478 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Thank you.
> 
> Though it might require emulator support first, do you think we can add a
> test case for this?

Sure.  The test might need a feature that could remove a SIM card from emulator (remove sim 1 in test case).
triage: basic function should work
blocking-b2g: 3.0? → 3.0+
(Assignee)

Updated

3 years ago
Blocks: 1147263
https://hg.mozilla.org/mozilla-central/rev/7714372f2bf5
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox39: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S9 (3apr)
status-b2g-master: affected → fixed
This issue is verified fixed on the latest Nightly Flame KK  3.0 build.

Actual Results: Calls can be made when using a single SIM in slot 2 of the phone.

Environmental Variables:
Device: Flame 3.0 KK (319MB) (Full Flash)
BuildID: 20150401010204
Gaia: 03164bd160809747e6a198e0dba1b7c3ee7789f5
Gecko: 18a8ea7c2c62
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-master: fixed → verified
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
status-b2g-v2.5: --- → verified
status-b2g-v2.5: verified → ---
You need to log in before you can comment on or make changes to this bug.