If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Aurora build shows a No Mail Accounts message on startup

RESOLVED FIXED

Status

()

Firefox for iOS
Build & Test
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: st3fan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Because the MFMailComposerViewController is created immediately when the app starts, people who have not configured a mail account on their device are greeted with a "No Mail Accounts" message.

There is a note in the code that the global MFMailComposer is a workaround for some bug. But maybe we can live with that bug and just allocate it at the moment a screenshot is made. (That is normal usage anyway - I don't think it should be reused)
Duplicate of this bug: 1147252
(Reporter)

Comment 2

3 years ago
Created attachment 8583074 [details] [review]
PR: https://github.com/mozilla/firefox-ios/pull/273

I have removed the workaround where the MFMailComposeViewController is created at startup because without it things also seem to work fine. This gets rid of the 'No Mail Accounts' alert when the application starts.
Attachment #8583074 - Flags: review?(wjohnston)
Comment on attachment 8583074 [details] [review]
PR: https://github.com/mozilla/firefox-ios/pull/273

Nice!
Attachment #8583074 - Flags: review?(wjohnston) → review+
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.