(Global?) search results attributed to wrong account

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
4 years ago
a month ago

People

(Reporter: karl-eric.backman, Unassigned)

Tracking

31 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Created attachment 8580089 [details]
Skärmklipp.JPG

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150305021524

Steps to reproduce:

I have many mailboxes. Thunderbid 31.5.0.
I seach for a word.




Actual results:

I got correct results BUT wrong information about which mailbox which has receved the answer.


Expected results:

Correct mailbox.
(Reporter)

Comment 1

4 years ago
ADDITION FROM USER The incorrect mailbox showed is one of the mailboxes we have set up. But not the correct one.
Karl, which type of search was used?
Global Search (Ctrl+K)?

I do recall having seen a problem in my own installation where global search results, in the preview results, were misattributed to one of my own accounts. So I believe this is a real problem.
Summary: Wrong information in seach result. → (Global?) search results attributed to wrong account
(Reporter)

Comment 3

4 years ago
Tried again today. It is CRTL-K.
BUT today, another of oor mailbox we have in out set up was shown. 
Still the wrong one.
(Reporter)

Comment 4

4 years ago
Created attachment 8581094 [details]
Second time. Another...
(In reply to Karl-Eric Backman from comment #0)
> Actual results:
> BUT wrong information about which mailbox which has receved the answer.

What do you call by "mailbox" in this contet?
(a) Message Folder name in Thunderbird where mail is held
(b) Subjext text of messge which is wriiten in Subject: header
(c-1) "FirstFrom LastFrom" part in "FirstFrom LastFrom <localpart@domainpart>" of From: header
(c-2) "localpart@domainpart" part in "FirstFrom LastFrom <localpart@domainpart>" of From: header
(d-1) "FirstTo LastTo" part in "FirstTo LastTo <localpart@domainpart>" of To:/CC: header
(d-2) "localpart@domainpart" part in "FirstTo LastTo <localpart@domainpart>" of  To:/CC:  header

What do you call by "wrong"
(e) Diferent fro data in message source
(f)  Diferent fro data in address book
(g) Different from string you want
Whai at where is correct one? What is shown as "wrong one" in seaarch result?

If (c-1) or (d-1) is wrong or different from ecxpected one, I know following which was reported to a forum.
(1) Sender sent mail with "From: AAA BBB <abc@def.ghi.jkl>" to you,
      or you add Contact for abc@def.ghi.jkl with displayname="AAA BBB",
      and sent mail with "To: AAA BBB <abc@def.ghi.jkl>".
(2) Indexed by Gloda, and association of  "abc@def.ghi.jkl -> AAA BBB" is generated in Gloda's DB.
(3) Sender changed displayname, and sent mail with "From: Xyz Xyz <abc@def.ghi.jkl>" to you,
      or you corrected wrong displayname of Contact for abc@def.ghi.jkl and changed to displayname="Xyz Xyz ",
      and sent mail with "To: Xyz Xyz <abc@def.ghi.jkl>".
(4) Search via Ctrl+K.
      Because of (2), and because Gloda always shows search result using (2),
      "AAA BBB" is always shown for mail address of abc@def.ghi.jkl.

Workaround if above problem:
- Delete mail of (1), Force recreation of Gloda's Indedex, if needed, move back mail of (2).
   Because assosication of  "abc@def.ghi.jkl -> Xyz X" is generated in Gloda's DB, problem is resolved. 
- Or change/remove Gloda's DB(SQL Taable) entry for (1) using Firefox + SQLite Manager.
  Sqlite file = global-messages-db.sqlite
(Reporter)

Comment 6

4 years ago
MY ANSWER===============================
I would like to put it in this way:

We have a couple of "mailboxes" something like...

karl-eric.backman@abcde.fg(Karl-Eric Backman)
anna_backman@abcde.fg(Anna Backman)
ebba.backman@abcde.fg(Ebba Backman)
Charlottebackman@abcde.fg (Charlotte Backman)

I made a search for some mailmessages with the word "oringen" in text or address.
All of theses is received by karl-eric.backman@telia.se and the messages are still in folders under "karl-eric backman"...

The first CTRL-K search you can see in the picture that Thunderbord shows that the messages are in 
"Anna Backman"s folder. In this folder there are no such messages.

The second CTRL-K search you can see in the picture that Thunderbord shows that the messages are in 
"Charlotte Backman"s folder. In this folder there are no such messages.

But when I did the same search today a few days later, thunderbird shows that the same messages are in "Karl-Eric Backmans"´s folder.  For the first time it is correct.

===============================
(Reporter)

Comment 7

4 years ago
Created attachment 8581877 [details]
Third cut.JPG

The third cut... Same search - same files - different "mailbox"...
Fields you pointed are:
   Right side of subject : From mail address
   after till:                   : recipent's mail aaddress = To mail address(may be CC)
Once mail is downloaded from server to Tb's mail folder, mailbox at server ie irrelevant.
Please explain by term or data in message source of the mail, instead of "someone's folder" or "someones's mailbox" like words
If you do following, you can see what happens.

1. Define Tags: tagAB, tabBB, tagCB, tagKB.
2. Pick up a mail which has "oringen" in messae body and  for which "wrong mailbox which you call" was shown by seach via Ctrl+K.
    If mail from  karl-eric.backman@abcde.fg(Karl-Eric Backman),      add tag named tagKB
    If mail from  anna_backman@abcde.fg(Anna Backman),               add tag named tagAB
    If mail from  ebba.backman@abcde.fg(Ebba Backman),                add tag named tagEB
    If mail from  Charlottebackman@abcde.fg (Charlotte Backman),   add tag named tagCB
    Only one mail has tag of one of tagAB, tagCB, tgEB, tagKB
3. Do search by Ctrl+K
4. Check message source of mail for which wrong information is shown.
    If the mail has tagAB, tagCB, tagEB, tagKB, it's mail from Anna, Charlotte,  Ebba, Karl-Eric, respectively.
5. View messaage source of mail picked up at step 2.
    tag data is writte in X-Mozilla-Keys: header, so this is the mail to which tag was added.

What is set in From: header, To: header? How about Sent: header, Delivered^To: header?
> What is set in From: header, To: header? How about Sent: header, Delivered^To: header?

Karl?
Flags: needinfo?(karl-eric.backman)
Whiteboard: [closeme 2018-10-15]

Comment 11

a month ago
Resolved per whiteboard
Status: UNCONFIRMED → RESOLVED
Last Resolved: a month ago
Flags: needinfo?(karl-eric.backman)
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 2018-10-15]
You need to log in before you can comment on or make changes to this bug.