Pasting in a multilined URL in to the URL bar only displays the first line

VERIFIED DUPLICATE of bug 23485

Status

VERIFIED DUPLICATE of bug 23485
17 years ago
10 years ago

People

(Reporter: dereks, Assigned: hewitt)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:0.9.6+)
Gecko/20011210
BuildID:    2001121008

When pasting a mutlilined URL in to the URL bar only the first line is printed
out in the URL bar

Reproducible: Always
Steps to Reproduce:
1. Enter vi from Terminal; change to edit mode
2. type in "http://" return "www.apple.com"
3. Copy those two lines
4. Enter Mozilla; Select the URL bar; Paste

Actual Results:  "http://" is printed to the URL bar

Expected Results:  "http://www.apple.com" should be printed to the URL bar

vi was used just as an example a real world example would be if you were using
epic and someone posted a multilined URL you'll get the same resault
(Reporter)

Comment 1

17 years ago
btw: A good was to test this in the best, ok, worst point-of-view

best: Paste the multilined URL in IE (thats what Mozilla should do)

ok: Paste the mutltilined URL in OmniWeb (Its pasted but the paste add returns
very ugly)

worst: Mozilla (above)

Comment 2

17 years ago

*** This bug has been marked as a duplicate of 23485 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
mass-verifying Duplicate bugs which haven't changed since 2001.12.31.

set your search string in mail to "CitizenGKar" to filter out these messages.
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.