Firefox doesn't update to the latest version when an update for an earlier version is already in progress

RESOLVED DUPLICATE of bug 353804

Status

()

Toolkit
Application Update
RESOLVED DUPLICATE of bug 353804
3 years ago
3 years ago

People

(Reporter: s3phy, Unassigned)

Tracking

36 Branch
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150305021524

Steps to reproduce:

I have a Windows installation that I rarely use. Everytime I use it (every few months), my Firefox installation is of course lagging by a few versions.

Now, when I start Firefox, and check "About Firefox...", it looks for new versions, and sure enough, it founds one, downloads it, and install it. Great.

Except that after a restart, and checking "About Firefox..." again, well the Firefox version that was just downloaded and installed wasn't the latest. Firefox realises this and downloads this new versions, and installs it. Again. Now I'm at the latest version.

Why didn't the auto updater grab the latest version in the first place? Why does it have to download an "intermediate" version?

I'm filing this bug because this is not the first time this happened to me. I find this frustrating, and also time and bandwidth consuming. Today, I just witnessed my Firefox 33 first upgrading to 34.0.5, then to 36.0.1. Why not going to 36.0.1 directly?


Actual results:

Auto-upgrade did work but had to download an "intermediate" version/had to be run twice to get to the latest Firefox release.


Expected results:

Auto-upgrade should directly download and install the latest version of Firefox, like I would if I was upgrading manually.

Updated

3 years ago
Component: Untriaged → Application Update
Product: Firefox → Toolkit

Updated

3 years ago
Summary: Firefox doesn't auto-upgrade to the latest version → Firefox doesn't auto-upgrade immediately to the latest version but passes by intermediate versions
Whiteboard: [DUPEME]
Summary: Firefox doesn't auto-upgrade immediately to the latest version but passes by intermediate versions → Firefox doesn't update to the latest version when an update for an earlier version is already in progress
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Whiteboard: [DUPEME]
Duplicate of bug: 353804
You need to log in before you can comment on or make changes to this bug.