"download anyway" link produces attempt to install instead of simply downloading

RESOLVED WONTFIX

Status

addons.mozilla.org Graveyard
Public Pages
RESOLVED WONTFIX
3 years ago
a year ago

People

(Reporter: Felix Miata, Unassigned)

Tracking

Details

(Whiteboard: [seamonkey-2.33-wontfix] [seamonkey-2.39-affected] [seamonkey-2.43-affected])

(Reporter)

Description

3 years ago
UA ID: Mozilla/5.0 (X11; Linux i686; rv:36.0) Gecko/20100101 SeaMonkey/2.33; Build ID: 20150308222504 

To reproduce:
1-open https://addons.mozilla.org/en-US/firefox/addon/classicthemerestorer/ in SeaMonkey [1]
2-left click "Download Now" button
3-left click "download anyway" link in the popup

Actual behavior:
1-no file picker dialog to choose location to save or filename to use
2-SeaMonkey attempts but fails to install

Expected behavior:
1-file picker opens
2-file is saved to location of choice with timestamp matching file on addons server

Comments:
1-attempt to wget the "download anyway" link from context menu saves with obtuse filename instead of classic_theme_restorer_customize_ui-1.2.9.6-fx.xpi that is saved to disk performing same operation using a non-Mozilla browser (e.g. Konq 3).
2-using context menu's save link target as disregards Preserve Download Modification Timestamp addon, saving classic_theme_restorer_customize_ui-1.2.9.6-fx.xpi with current timestamp instead of the timestamp of the file on the server.

[1] or https://addons.mozilla.org/en-US/firefox/addon/dark-youtube-theme/?src=api or any other extension that is invalid for SeaMonkey

Comment 1

3 years ago
Think this is a seamonkey bug, not an amo one.
Component: Code Quality → General
Product: addons.mozilla.org → SeaMonkey
SeaMonkey 2.33 is obsolete, the current "stable" SeaMonkey is 2.39, and even that is going to be obsoleted when 2.40 is released in a few days.

However, I could reproduce the bug in 2.43a1 trunk, even with the "AMO Browsing for SeaMonkey" extension, version 0.9.9.

UA:"Mozilla/5.0 (X11; Linux x86_64; rv:46.0) Gecko/20100101 Firefox/46.0 SeaMonkey/2.43a1" ID:20151216003001 c-c:cace0ff88a9c0c2d3d56037b9e7c58f8eece4105 m-c:e6463ae7eda2775bc84593bb4a0742940bb87379 en-US

Test 1 (not in Safe Mode, AMO Browsing for SeaMonkey enabled). There is a big blu button saying "Check if SeaMonkey version is available". Clicking that brings us back to the Firefox extension page, meaning that the extension does not support SeaMonkey. If at that point I click "Download anyway", a doorhanger appears with a progress bar for the download, and then the progress bar is replaced in the doorhanger by an error message, "Classic Theme Restorer could not be installed because it is not compatible with SeaMonkey 2.43a1", meaning the install was attempted at that point and failed because there is no <targetApplication> section for SeaMonkey in the install.rdf (if there had been one, or one for toolkit@mozilla.org, my extensions.checkCompatibility.nightly = false setting would have taken care of it).

For Test 2 (in Safe Mode, where all extensions are temporarily disabled) I have to restart, so first I shall submit this comment.
status-seamonkey2.39: --- → affected
status-seamonkey2.43: --- → affected
Hardware: x86 → All
Whiteboard: [seamonkey-2.33-wontfix]
Version: unspecified → Trunk
Test 2 (in Safe Mode, which temporarily disables all extensions, and in particular the "AMO Browsing for SeaMonkey" extension). Instead of the blue button mentioned in comment #1 there is an even bigger green button saying "Only with Firefox — Get Firefox Now!", which I don't click (it leads to https://www.mozilla.org/firefox/new/? with a longish query-string. A few lines lower, the "Download Anyway" button is still there. Let's try to click that: it leads to https://addons.mozilla.org/firefow/downloads/latest/472577/addon-472577-latest.xpi?src=dp-btn-primary

The doorhanger with progress bar and failed install appears just as in comment #1.

Andy, could you please try the converse test on Firefox? Browse to the add-on page for some extension which supports SeaMonkey but not Firefox, let's say "Last Dictionary for Mail", https://addons.mozilla.org/en-US/seamonkey/addon/last-dictionary-for-mail/ and try to "Download anyway" (don't start at a Thunderbird page because AMO has special code on Thunderbird pages which disables install and forces download). If you get a directory chooser it's a "success", and you may "cancel" the download at that point; if Firefox downloads the add-on and then notifies you that it tried to install and failed, then it's a "fail".

I'm asking because a "success" (i.e. a directory chooser) on Firefox might mean a problem in SeaMonkey as you thought, while a "fail" in Firefox would point to either AMO or the Toolkit Add-ons Manager.

If OTOH you can't get a "Download anyway" link at all, not even in a popup, then the problem might reside either with SeaMonkey or in a difference in how AMO treats Firefox on SeaMonkey pages OT1H, and SeaMonkey on Firefox pages OTOH.
Flags: needinfo?(amckay)
P.S.: @Felix Miata (and anyone interested): The "AMO Browsing for SeaMonkey" extension makes AMO much more SeaMonkey-friendly, and in particular it suppresses the shtoop'd "You must be using Firefox 10.0 or later" popup, but it isn't yet found at AMO. You can download the latest version (and all earlier ones) at http://addonconverter.fotokraina.com/amo-browsing/

Comment 5

3 years ago
(In reply to Andy McKay [:andym] from comment #1)
> Think this is a seamonkey bug, not an amo one.
On the other hand it might be that AMO is serving up the file with the wrong mime type?

Comment 6

2 years ago
(In reply to Tony Mechelynck [:tonymec] from comment #3)
> Andy, could you please try the converse test on Firefox? Browse to the
> add-on page for some extension which supports SeaMonkey but not Firefox,
> let's say "Last Dictionary for Mail",
> https://addons.mozilla.org/en-US/seamonkey/addon/last-dictionary-for-mail/
> and try to "Download anyway" (don't start at a Thunderbird page because AMO
> has special code on Thunderbird pages which disables install and forces
> download). If you get a directory chooser it's a "success", and you may
> "cancel" the download at that point; if Firefox downloads the add-on and
> then notifies you that it tried to install and failed, then it's a "fail".

It tries to install the add-on.
Flags: needinfo?(amckay)
(In reply to Andy McKay [:andym] from comment #6)
> (In reply to Tony Mechelynck [:tonymec] from comment #3)
> > Andy, could you please try the converse test on Firefox? Browse to the
> > add-on page for some extension which supports SeaMonkey but not Firefox,
> > let's say "Last Dictionary for Mail",
> > https://addons.mozilla.org/en-US/seamonkey/addon/last-dictionary-for-mail/
> > and try to "Download anyway" (don't start at a Thunderbird page because AMO
> > has special code on Thunderbird pages which disables install and forces
> > download). If you get a directory chooser it's a "success", and you may
> > "cancel" the download at that point; if Firefox downloads the add-on and
> > then notifies you that it tried to install and failed, then it's a "fail".
> 
> It tries to install the add-on.

This points to either an add-on manager bug (in Toolkit), or (if Philip guessed right in comment #3) an AMO one… Let's toss a coin…
status-seamonkey2.39: affected → ---
status-seamonkey2.43: affected → ---
Component: General → Public Pages
Product: SeaMonkey → addons.mozilla.org
Version: Trunk → unspecified
@Toolkit / AMO guys: FWIW, to get the Gecko/Toolkit version from the SeaMonkey version, add 3 to the minor version (starting at SeaMonkey 2.2 / Gecko 5).
Whiteboard: [seamonkey-2.33-wontfix] → [seamonkey-2.33-wontfix] [seamonkey-2.39-affected] [seamonkey-2.43-affected]
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
Nothing in Graveyard is ever going to be fixed.

Feel free to move this bug to a different Product::Component if there is a chance to have it fixed there.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.